Rhino Inside Revit Start Up Problem

I have a valid Rhino 6 license and have installed Rhino WIP, however Revit 2019.2 crashes when I attempt to open Rhino Inside Revit referencing error 200.

image

Did you open the WIP by it self, and set the key, it doesn’t automatically register the license in some cases.

Hi Greg,

Thank you for your reply.

The Rhino WIP that I have downloaded is version 7, but I have a version 6 Rhino license.
I did not receive an email from McNeel for the Rhino WIP license.
I have uninstalled Rhino WIP, downloaded another version , but I get the same result.
The licensing is arranged by our IT, but they claim no knowledge of any Rhino key email.

Should I contact sales@mcneel.com to follow up ?

Thanks for your help.Rhino%207%20WIP

Hi - the WIP of Rhino 7 uses the same license as your Rhino 6 installation.
So, depending on how that is set-up on your end, you should just do the same as you did for Rhino 6. I guess that you need to click Join a Team.
-wim

Thanks Wim,

We have still not been able to run R4R and have now placed an official support requst through our reseller to McNeel.

Will post results when to hand.

Will

Wgow,

In another entry on this forum (that I cant find now), it is explained that an error -200 means there is another of your Revit plugins crashing with Rhino Inside. In my case, it was Naviate. I had to uninstall Naviate.

Thanks Libby.
I have many Revit plugins, but not Naviate.
Hopefully McNeel Support will resolve.
I’ll let you know more when I hear.

Have you looked at this page. There are a few tools @eirannejad recommends to use:

Hi Scott,

Thank you very much or your detailed reply.

I have disabled all Revit Add-Ins , that can be disbaled (Note, Stantece will not disable all - refer images below )
I now receieve the following message when attempting to run Rhino Inside Revit:-

Grasshopper%20Image

After that, i receive the Error 200 and Revit crashes.

Grasshoper is available in RhinoWIP and Rhino 6 , when run independly of Revit.(Build 1.0.0007 )

These are the Revit Add-Ins which cannot be disabled from the Stantec Addin Manager …


And this is the warning that is received, referring to “Cannot Rename” for some reason:-


I have also attached the RhinoDotNetCrash.txt file…

RhinoDotNetCrash.txt (537 Bytes)

Hoping that this can be resolved.

Cheers
Will

Hey @wgow
Would you mind submitting the Revit Journal file as well? They are located under %LOCALAPPDATA%\Autodesk\Revit\Autodesk Revit 2019\Journals

Hi Ehsan,

Thats not a problem.
Thanks
journal.0491.txt (171.2 KB) journal.0490.txt (170.8 KB) journal.0489.txt (177.4 KB) journal.0488.txt (212.9 KB)

And this is the dump file from earlier.

dump.0374.txt (77.7 KB)

Cheers
Will

Hey @wgow
So I can see the error but it is odd. Seems like Revit can’t resolve the command name. It actually did the same on my machine and had the same error. But installing the most recent version fixed the issue and Rhino is starting OK in my Revit.

Here is the error in the Revit journal

' 1:< External Command Registration Exception: Invalid long description format.
'An error occurred while parsing EntityName. Line 2, position 41.

Would you mind downloading the installer again, setup and test?

Hi Eshan,

I uninstalled and re-installed Rhino Inside Revit, but have the same result.
I have attached the Journal File and the Dump file.
The same error is reported.

journal.0493.txt (171.0 KB) dump.0375.txt (92 Bytes)

Regards

Will

Hey @wgow
Okay so I looked into this last journal and compared to the previous and seems to be the same issue. Are you using a non-english version of Revit by any chance? It seems like Revit has a problem with the command code and I’m trying to investigate why.

Hi Eshan,

I’m using an English version of Revit.

Regards

Will