License Manager initialization failed with error -200


I’m experimenting with the RiR add-in for Revit (2019) and keep running into this error, followed by an exception crash as follows

Error HRESULT E_FAIL has been returned from a call to a COM component.
at Rhino.Runtime.InProcess.RhinoCore.Startup(Int32 argc, String argv, StartupInfo& info, IntPtr hostWnd)
at Rhino.Runtime.InProcess.RhinoCore…ctor(String args, WindowStyle windowStyle, IntPtr hostWnd)
at RhinoInside.Revit.Revit.OnStartup(UIControlledApplication applicationUI) in

I can start the WIP Rhino with no issues and the Rhino 6 (both showing the version 6 serial number) so I assume they are both licensed

The Rhino-behind Revit starts but of course no buttons in Revit are created

Any help would be appreciated


You need to use the Rhino WIP for V7 in order to experiment with Rhino.Inside technology

I do have the V7 WIP installed, do I need to remove the non-WIP Rhino 6? is it causing confusion between the different versions?

You shouldn’t have to remove V6. Maybe @kike can help figure out what is happening.

Please start Rhino WIP using the desktop icon and enable debug logging like this:

-_TestEnableDebugLogging _Enable=Yes _SaveTo=File

Then close and restart Rhino from Revit. When it crashes a file named RhinoDebugMessages.txt will be created in your Documents folder. Please send that to me - it should help me see what is going wrong.

Thanks for your reply; I’ve attached the file here - hope it has something helpful

RhinoDebugMessages.txt (7.8 KB)

I need some more help.

Please unzip and open the file “Enable RhinoSDK Messages.reg
Then run again Rhino inside Revit.
Some message boxes should appear.
Please capture those messages using some screenshot tool like Windows Snipping Tool and send it back to me.
Remember to open the “Disable RhinoSDK Messages.reg” to turn those dialogs off again.

The first message stayed the same but the second one is better, I’ve attached both here



Hope this is more useful, let me know what I can do next to help

It seams you are using Windows 10, but could you please confirm me the exact version and also tell me if it is a server edition or not?

Apologies for the late reply, been away from the work PC;

I am running windows 10, its an “Enterprise” version; Version 10.0.16299 Build 16299
and no, its not a Server edition.

Did you try “Repairing” V6 in Control Panel?

Just tried it - didn’t work, unfortunately, still same error (at least I think its the same); the error -200 and then the following:


Could you please try to generate a dump file of the Revit process when you have this message box on screen?

  1. Press Ctrl+Mays+ESC Task manager will open…
  2. Go to the details tab.
  3. Right click on Revit.exe
  4. Select “Create dump file”
  5. A file called “Revit.dmp” will be create in your temporary folder. Use to be "C:\Users\%USERNAME%\AppData\Local\Temp".
  6. Please ZIP this file and send it to me using this link to as e-mail recipient.

I’ve just submitted the dump, it was taken as soon as the -200 message popped up. Hope it sheds some light on what weird things I have in here that cause the problem.


Analyzing the dmp file seams that you generated it when Rhino was stopped on the first dialog.
Could you do it while the second dialog is on screen?

I’ve re-uploaded the 2nd file again - i think the first one might not have gone through. Please let me know if you find out anything. Thanks

I’m sorry, maybe I was confusing in my previous message, but in order to make this useful I need you generate the .dmp when this dialog is on screen.


Please follow instructions on the previous post about before generate the .dmp.

Sorry bout that - I thought thats what I did - maybe i sent the wrong one. I’m just uploading the dump with the second message on the screen (looks a little different so I’m not sure if I missed a step somewhere - if it’s still wrong i’ll try again tomorrow)

hope its what you are looking for this time

Your last capture shows the same message as in the first post

In the 9th post you showed me this other capture.


The content is different

“Could not load file or assembly ‘Microsoft.WindowAPICodePack.Shell’, Version=,…”

If you can reproduce this again, please capture the dmp.