RhinoInside not finding Revit categories/ levels/ etc

I’m having an issue where RhinoInside does not seem to be able to pull any info out of Revit.

We’re using Revit 2019.2, with the latest Rhino WIP and RIR build (downloaded today).

Any thoughts or suggestions? We’ve tried restarting the computer, made sure that RIR launches from the right Revit document, and a few other things, but nothing seems to work.

1 Like

I am running into a similar Issue. I had not opened RIR for a week or so and ran the new updated installer last night around around 8 PM PMT since I was running into the very issue posted on the forum last yesterday. See link here:

The above thread fixed the issue of getting RIR to open within Revit. However, after running the installer last night I now running into the same issue as @Matthew_Breau when trying to use any sort of picker. This is what I am getting from RIR/GH

I have tried to use the other options of dropdown, checkbox, etc. in the settings for the picker component as well as other ways trying other ways to grab/filter categories and am and am getting the same result. That being said I can build geometries in grasshopper with their native components and they translate to both Rhino.Inside and Revit so I know the active doc is linked.

Is there any Suggestions or advice or could this be a bug from the new installer that we updated yesterday 12/4? Along those lines, I am wondering if any one has had this issue on other versions of Revit? I am running Revit 2019.2


I did a change to try to detect what happens there.
It seams that Rhino.Inside is not receiving the Idle event.

Please update your RiR copy and give it a try.

After installing maybe all of your buttons in the Rhino tab will be disabled, this will confirm the Idle problem.

Thanks for testing.

Hey Kike,
Thanks for the Response.

I went ahead and downloaded the most recent RiR installer package and ran a reboot on my machine. I am getting the same result as I was previously where no buttons in the Rhino tab were disabled permanently. I did however notice that when I ran RiR initially, as long as I didn’t click on anything immediately after, the buttons seemed to be disabled. This is different than previously where the Rhino Ribbon Buttons were immediately active in Revit before.

That being said, the moment you click to execute a command it seems to become enabled again.

From there I am to open RiR as I was before, but I seem to be getting the same errors.


Could you please follow instructions here to try to find if it is a compatibility problem with an other Addin?

Please share here what you found.


I have every addin except RhinoInside disabled, and I am getting this error. Prior to disableing all of the addin, I was getting a different error. It was complaining about not connecting to the document and an error in a cpp file for FilteredElementCollector.

I am getting the same error with everything in the Build menu too.

I am getting the same error with the family picker.


There is a new installer.
Could please test it and tell me?

1 Like

Hey Kike,

I was able to get the new installer on my machine this morning and everything seems to be working in terms of the model picker. Thank you!

Confirmed. Category pickers work now.

Just got back from vacation, confirmed its working here as well. Thank you!

1 Like