Rhino.inside doesn't show in Revit addin ribbon

Hi, I have downloaded the latest version of Rhino.inside (dated 8.8.2023). But Revit doesn’t identify it; it doesn’t ask for permission to load it nor does it show up in the top ribbon next to the addins.
Btw I have Revit 2023 educational license and Rhino 7.19 commercial license.
I tried the solutions I found regarding fixing the addin path and Windows registry editor and I have the files in both program data and program files, but nothing worked :frowning:

Screenshot 2023-10-07 105244



Any idea what to do?

Hi Pebbles, Rhino.Inside is broader category, for Revit specific help please use the Rhino.Inside - Revit forum category.

Lets get you on the Latest Rhino and try again. Minimum version is 7.28 Rhino.Inside®.Revit

https://www.rhino3d.com/download/rhino-for-windows/7/latest/

I have updated rhino to 7.33 and still addin not loading inside revit

This could be due to a plugin conflict, you can either move them from the current folder or use this addin to temporarily remove. Rhino.Inside®.Revit

Ok here it is
PebbleLog.txt (9.9 KB)

I disabled all plugins and not yet : )

This is a Revit Addin conflict 99% of the time. What do you have loading in Rhino? Can you type SystemInfo in the Rhino command line and post the results. Thanks!

Rhino 7 SR29 2023-4-17 (Rhino 7, 7.29.23107.03001, Git hash:master @ 5f05ef3a2eea3d910c4c2fb79ccc75b413d33ca7)
License type: Corporate, build 2023-04-17
License details: Stand-Alone

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 7.9Gb)

Computer platform: LAPTOP - Plugged in [99% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 7-29-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1650 Ti (NVidia) Memory: 4GB, Driver date: 4-5-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 462.30
> Integrated accelerated graphics device with 1 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-5-2021
Driver Version: 27.21.14.6230
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\lenovo\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ggRhinoIFC\23.10.4.0\ggRhinoIFC.rhp “ggRhinoIFC” 23.10.4.0
C:\Users\lenovo\Downloads\blockeditex.rhp “BlockEditEX”
C:\Users\lenovo\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\Bullant\23.2.27.0\bullant.rhp “bullant” 23.2.27.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Users\lenovo\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\lenovo\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Apologies on the the slow responses, a travel and conference week.

Lets disable the Rhino 3rd party plugins and restart Rhino. In Rhino (Revit is closed) go to File>Properties>Plugins , filter by 3rd party plugins and disable via the check boxes. Close Rhino and then attempt to open RiR.

1 Like

Nope not yet
If you ever want to AnyDesk me and see what could be the problem; that’d be awesome : )

Hello,

maybe a stupid question - did you try to uninstall RiR completely, start Revit without RiR, close Revit, restart PC, and then install RiR again?

Pavel

3 Likes

This is absolutely nuts :laughing: It worked!
Thanks, Pavel and Japhy you guys rock!