Rhino flickering when an Autocad layer is turned on


#1

Hello everyone !

I have a Rhino file with an imported Autocad drawing which I have put on a layer. This drawing is quite “heavy”, it has a lot of information since it is an urban drawing of a city, with building plans, roads and so on.

As I turn off the Autocad layer, everything looks fine but when I turn it on, some of my 3D volumes (on an other dedicated layer) start flickering, like volumes seem to be out of their “box” or I can see the inside of the volume while I am in Shaded mode …

Is this related to the heavy Autocad layer ?

Thanks for your help !


(Wim Dekeyser) #2

By the sounds of it it might have to do with your model being far away from the origin. Does it look any better if you move everything to w0 and refresh the display meshes? (ClearAllMeshes)


#3

Before posting this topic, I move everything to the origin as it was indeed quite far from it, but it did not change anything.

I tried your method and again, no improvement …


(Wim Dekeyser) #4

Can you post the file? Or at least part of it that is enough to demonstrate the problem?


#5

Okay, I post here part of the Rhino file !
The problems seems to appear only at the posts of the grey building near the bridge (the model is not clean or fancy at all, it is just a study model).

(The flickering surfaces you see are the Autocad hatches that I have not deleted before importing the file)Untitled.3dm (6.2 MB)


(John Brock) #6

The file has a lot of duplicates in it.
Run SelDup and delete the extra ones.
Does that help?


#7

Wow I actually had lots of duplicates, don’t know where they came from, thanks for that !

But the problem remains …


(John Brock) #8

I’m not getting any flickering.
What display adapter are you using?
Options > View > OpenGL


#9

Ok so when I have a look at OpenGL, here is what I see :

Antialiasing : 4x
Mip Map Filter : none
Anisotropic filter : none

(I translated these parameters from French so not sure if they are 100% correct in English)

(I post you here what kind of flickering I see)


(John Brock) #10

Anyway, I have an old MBP with an nVidia GeForce. If I increase the antialiasing to 4x it helps. I usually leave AA at none so it’s a bit faster.

Rhinoceros > Preferences > OpenGL


#11

These posts are the only element that cause this kind of flickering problem …

I don’t know why it is related to the turning on and off of the Autocad layer … That’s not a big problem, just a bit annoying as it does not look clean …


(John Brock) #12

The Hatches on that AutoCAD layer are all stacked up over each other too. You could just be running out of video memory.


(John Brock) #13

Apple menu > About this Mac > System Report > Graphics/Displays will tell you about your display adapter and how much VRAM you are to work with.


#14

Yes I know about the hatches, I hided them to avoid the flickering effect on them.

I have a last off-topic question : is there a way to extrude curves at different heights at the same time without Grasshopper ?

Thanks !


(Wim Dekeyser) #15

Have you tried? There is no requirement that curves should be at the same elevation for them to be extrude-able.


#16

I don’t mean to extrude curves that are at different elevations but I would like to extrude several curves that are actually at the same elevation but I’d like them to have different to have different heights, like volumes of different size. Is it possible to do it without Grasshopper ?


(Wim Dekeyser) #17

No, not at the same time.