Rendered display mode Issues in Rhino 7 SR13

Hi, for a long time I have some issues with the Rendered display mode.
Normally the default rendered display mode is a nice beautiful ‘physical-model-alike’ view.
In some other situation (mostly by larger files with lots of 2d-geometriy-block etc.) is the default rendered display mode pretty bad looking (almost like shaded mode).

Here two screenshots:

  • the first one the main file I am working in (besides the 3d geometry there are lots of imported dwg blocks (2d architectural drawings, plans etc.))
  • in the second file I just copied the 3d geometry & the rendered view here is perfect.

Has anyone come across this before and found a solution?

Anytime you have imported geometry, you have a large risk of “bad objects”.
I’d start by running SelBadObjects and see what you find.
Since you mentioned AutoCAD specifically, another command to run is SelDup.

I’d recommend doing that every time you import geometry into Rhino.

And yes, we can obviously see the difference, but you didn’t supply a sample file to determine why.

I’ve made a couple common guesses based on experience.

Hi John, Thanks for the fast respond!

I tried SelBadObjects and found one object that I deleted. I tried SelDup as well and deleted a couple of duplicated objects as well. Unfortunately the view is still not nice. The imported objects are dwg files exported from ArchiCad .

It would be perfect, if you take a look.

Thanks again!

Hello - turn on the skylight in the Lights panel. Does that do it?


Hi Pascal, yes! Perfect!

Thank you very much!