Rhino File openning "Not Responding"

Hi All,

I have a Rhino6 Installed in one of my users. It worked alright for more than year now but suddenly there is pretty annoying error. It starts up and Loads pretty nicely initially. but after that if we try to open a file from Open menu, it loads up file open window but application hangs without any trace. Sometimes it loads the file then hangs. The same happens when opening a file by double clicking. Sometimes it hangs when working on the first opened File. There is no option but to shut down the Rhino from task manager or task bar. After this all the other programs(Adobe Illustrator) which uses graphics also experience the same until a total restart.

All the Counters are normal( Processer 3-7 % , memory 19% ,GPU -0- 3% , )
The Machine is a Lenovo P52 with Windows 10 Pro for workstations - 1809 - build 17763.615 - , Intel Xeon 2.71 GHz processor, 32GB memory, 4 GB Nvidia Quadro P2000)

I’ve updated all the drivers also but no solution till the moment.

Your help is much appreciated.

Hello - please run the SystemInfo command in Rhino and post the results here.


Here is the output from SystemInfo Command.

Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Commercial, build 2019-07-09
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: NXT-LT-CKT004

Hybrid graphics system.
Primary display: Intel® UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 3-8-2019 (M-D-Y).
Primary OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 4GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.70

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\KithV\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.10.11.800\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

If you have issues with other programs along with Rhino, my suggestion is to test the system as a whole.

  1. Check wether your SSD has the TRIM function turned on. It’s vital for the longevity and speed performance of the SSD.

  2. Check the hard drive for bad sectors (I assume that your laptop has a separate SSD for the Windows OS, while the HDD is used for data storage). First and most important, make a back-up copy of your important files on some external storage. Then, close all programs, open “My computer” and right-click on the hard drive icon, then choose “Properties” and go to the “Tools” tab. From there, you will see “Error checking” and click on the “Check now” button underneath. Make sure to tick both boxes: “Automatically fix file system errors” and “Scan for and attempt recovery of bad sectors”. If there are bad sectors on the HDD, even if Windows manages to successfully fix (i.e. lock and make invisible) the issue, never use it for storage again. Just replace it with a brand new HDD.
    I had exactly that problem a week ago. My Windows 7 started to load for 2,5 minutes instead of 25 seconds as usual, and any program worked a lot slower than before.

  3. Make sure you have a new thermal paste applied to your CPU and GPU at least once a year. The thermal paste tends to lose its properties in 1-2 years after installation, resulting in a worse heat transfer, hence the reduced overall system speed due to underclocking of the CPU and/or GPU, increased fan speed and generated heat inside the laptop. Also, clean up the fan and radiators from the inevitable dust and cotton-like dirt.

  4. Download and use the following programs by “IObit” (they all have a free version with slightly limited functionality compared to the paid version): Advanced SystemCare (it consists numerous smaller programs to optimize the system), Driver booster (very fast and user-friendly automatic installer of latest drivers), Smart defrag (it will also allows you set TRIM to your SSD, although that should be on by default when the Windows 10 was originally installed), Mallwire fighter, and Software updater (also updates all aforementioned programs, so I suggest to install this one first). You can also install CCleaner, because sometimes it manages to clean and fix some problems that were not fixed by the free version of ASC (it will intentionally leave 10% of the issues intact unless you buy the full version). ASC also has an option to boost the system performance by stopping various processes. This usually releases about 200-500 MB of RAM and some CPU load.

Thanks for the Input B Design.
i did 1 and 2 and got all green results.
im not in a position to do both 3 and 4 but with 4 i am quite not sure because the performance variables hardly hit 25% of the capacity. not even 10%. All the other software runs very smoothly except for this error.

Something additional i noticed; This runs great on the original Windows Admin Account. but not any of the User Accounts; even when i create a New One for the testing purposes. the behavior is the same.

ASC and some of the other programs from “4” also fix errors with the user accounts and registry of Windows.

Hello - can you please try getting it into the ‘hang’ state and then force a crash dump as outlined here:


Please send the resulting file to tech@mcneel.com, and include a link back here to this thread.