Rhino crashing immediately

Windows ran an update last week and I believe that's when my problem started but I also installed a Rhino update last week so I'm wondering if that had anything to do with it. Every time I try to open rhino 6, it takes about 15 minutes and if it does open, it crashes whenever I go to click on the file tab to open a file. I am unable to do anything without it crashing and giving me a "not responding" error message. If I try to open a file without rhino open, rhino eventually comes up but in a black screen, "not responding" mode. I've tried uninstalling and reinstalling a bunch of times, updated the graphics drivers, I'm at a complete loss.

Have you tried starting Rhino in safe mode?

Rhino.exe /SafeMode

// Rolf

I just tried opening Rhino 6 in safe mode, same issue. The moment I clicked file to try and open a file, it froze up and had to be closed because it was "not responding."

If you do manage to get Rhino running without it crashing, can you run the SystemInfo command and post the results here?

Without changing anything, I was able to get rhino to run and even open a file, not sure what changed. Here's the system info:

Rhino 6 SR18 2019-9-23 (Rhino 6, 6.18.19266.14201, Git hash:master @ 3d84f88dec99b2f4e8b7497e739ed2adc2ba8ef6)
License type: Educational, build 2019-09-23
License details: Cloud Zoo. In use by: Sarah ()

Windows 10.0 SR0.0 or greater (Physical RAM: 12Gb)
Machine name: LAPTOP-T9PH6KFT

Non-hybrid graphics.
Primary display and OpenGL: Intel® HD Graphics 620 (Intel) Memory: 1GB, Driver date: 2-28-2018 (M-D-Y). OpenGL Ver: 4.5.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build
Driver Date: 2-28-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.18.19266.14201

Hi Sarah - I guess Intel 620 graphics are somewhat suspect when running Rhino 6 - I’d update the driver at least, to the latest available - look in the Notifications panel (Panels menu > Notifications) for a warning about drivers - double-click that if there is one and follow the prompts to get a driver update.