Rhino File is very large


I have made a rhino model and used grasshopper to apply a grid to a lofted double curved surface. This has made the file 2.5GB. Can anyone tell me why this is so large and if there is any way I can make it smaller without re doing the whole thing?

I have a deadline very soon and cannot export the model into any rendering softwares due to its size. Any help would be greatly appreciated.

Many thanks


Without seeing it, I’m guessing that the mesh that you are exporting is too fine. If your exported mesh file is too huge, try meshing manually first with the mesh command so that you can just make a mesh that’s fine enough but not too fine, then select the mesh and export it.

Dear Katie
how big is the file, if you Export it as .3dm with a new filename and choose the “save small” option in the save dialog ?
(this will save without render / analysing meshes …)
What happens if you copy / paste only the needed geometry to a new / blank file ?
…otherwise it is hard to guess without seeing the file.
kind regards -tom

1 Like

Hi I have tries saving small and it took off about 500MB, I have also removed all geometry that is not needed and purged the file which made very little difference. Is there anything else similar to this that i can do?

In the original file there were no meshes, just surfaces and poly surfaces (thousands of them!) I have tried meshing these which has made the file double the size. I am currently waiting for the ‘reduce mesh’ command to finish which has been running for over an hour now. As you can probably tell, I am very new to rhino, so sorry if all this sounds stupid!

If you tell us, or even show us, more we might be able to help. It seems to me that you are maybe choking rhino with something done in a very inefficient way, or even duplicated way.

Why do you have thousands of surfaces/polysurfaces? DO you have to have that many? or some tool/process made too many?

Do you have many curves too?

How about duplicate objects? you can try the _SelDup command and see.

How big dimensionally is your model? and what are your meshing settings of the surfaces/polysurfaces? go to tools>Options>Documemt properties> mesh


1 Like

The poly surfaces generated from grasshopper appear to be the problem, as they are very heavy, is there a way to rebuild polysurfaces other than converting them to meshes and reducing the mesh- this is taking an awfully long time as the meshes produced have hundreds of thousands of polygons and lines (even when made using the ‘fewer polygons’ setting), even though they very easily reduce to around 10-50 polygons each.

Yes, you can explode polysurfaces and then use rebuild command.

FYI: Rhino automatically creates a “render” mesh for every surface and polysurface which is used for display. These meshes are usually not directly accessible to the user. The refinement of these meshes is controlled by the parameters in Options > Mesh. The render meshes are saved in .3dm files unless the Save small option is selected or Save small command is used.

Hi Katie -

I’m assuming that the result of the Grasshopper definition is a bunch of objects without any materials and that you now need to get this out of Rhino somehow to get rendered in a different application.
What if you generate the meshes from the polysurfaces when still in Grasshopper? You can use the Settings (Speed) or the Settings (Custom) component to create a light mesh. Then, in Grasshopper, join all these meshes and bake that final result to Rhino. Does that result in an object that you can export?

What will the grid be used for?

Do you need a grid of points, a grid of lines, or a paneled surface?

Perhaps you need to back up and revise what your are creating and/or how you are creating it in Grasshopper.

Katie, I think David Cockey and the rest are summarizing your problem: you might be starting this with a very heavy (and maybe wrong) approach. I think that if you post a small sample of your GH logic/definition and we can see what you are doing we might be able to help a lot more.