Rhino doesn't display edges anymore / confuses surfaces / SOLVED :D

Hi there ! :slight_smile:

My Rhino (tried with 5.0.1 and 5.1 version on my Macbook) doesn’t display edges of my model anymore. It appears in any kind of view (Shaded, X-Ray, Render, etc).

1st example on video : https://www.youtube.com/watch?v=1m0fMOXH8Ek
2nd example on video : https://www.youtube.com/watch?v=gSSUU-JJuAM&feature=youtu.be

From a long distance view, there is no problem. As soon as I get closer to the edges, it starts to bug and some elements totally disappear. It makes the environnement impossible to work with which is kind of a problem :disappointed_relieved:

I tried to change all kind of parameters available in the display mode tools. No changes.
The origin of my drawing is although pretty close of my problem. Few meters only.
It also happens of any new file that I’d create. It is not a single problem of this specific .3dm file.

I have a Macbook Pro Retina Early 2013 with Intel Graphic HD 4000 as a video card.

Any idea to help me?
THANK YOU ! :pray:

FOUND IT ! :smiley:


How to solve the problem :

You have to place your drawing at the origin (0,0,0). But WARNING :
Each view can have its own origin. Be careful that your drawing is correctly placed more or less at the zone of your “plan view mode” origin. The other are not counting (perspective, right, etc).

-> Go to your plan view mode -> Select your working 3D -> Move it to (0,0,0).

The view in your perspective mode should be normal again.

Hi Valentin - you can specify the World origin with w0,0,0 - this will ignore the current CPlane coordinates.

-Pascal

Thank you very much !

Wow, never knew that! More great stuff from Pascal @ McNeel. I think you should get a raise, sir.

w0 will suffice for the world origin, and 0 for the CPlane origin. No need to type three zeros.