Rhino 7 crashing at startup

Hello guys, I am having crashes at startup recently, either in normal mode or in safe mode.

Sometimes it starts but crashes as soon as I do some clicks on the propreties sidebar or switch between the tabs…

Any idea?
I also sent some crash reports.

system info:

Rhino 7 SR37 2024-4-16 (Rhino 7, 7.37.24107.15001, Git hash:master @ d2e42f70b9d3aa58f6053e2998a0db2abcd7555b)
License type: Licenza lab educational, build 2024-04-16
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 1.3e+02Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port 0
- Windows Main Display attached to adapter port 1

Secondary graphics devices.
NVIDIA GeForce RTX 3090 (NVidia) Memory: 24GB, Driver date: 4-11-2024 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version: 31.0.15.5222
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I’m not seeing any crash reports or a Rhino 7 license with this account. Do you have a different email we can look at? feel free to message it to me privately.

A couple things help with troubleshooting.

  1. Lets disable Vray in Rhino>Properties>Plugins and restart Rhino.

  2. If you are still seeing the instability after testing step 1, try unplugging the monitors and testing again…

I uninstalled vray for rhino and the crash is still occurring.
Rhino starts but as soon as I use the sidebar tabs it crashes, sometime it gives me the option fro a crash report sometimes not.
Another weird thing, I noticed that after the crash I have the rhino process running in task manager and I am not able to kill it…
I am sending you my email .

Anyway I have the feeling that this issue is related to some connection issue…

It is crashing also if :slight_smile:

  • I check the licenses inside the settings
  • I click on advaced settings
  • I click on the cycles tab inside the settings

I’ll update the list as soon as I find any other crash

Thanks, i see you are on the Cloud Zoo Team. Unfortunately that email is not showing any submitted crash reports. If you repeat and ensure your email is correct when sending it would be very helpful. Thanks

This is happening in a blank file or in a particular one?

Blank file, anytime I open rhino.

Did this just start happening when installing 7.37? Do you have a previous installer you can try for troubleshooting purposes? It would be good to know if this is something in your environment or particular to the build. thanks.

I’ll send you a previous build in the PM as well.

1 Like

Installe a preview build with no luck, it also showing an artifact in the side tab:

It’s crashing anytime I try to undock it

Thanks for testing. This is pointing toward potentially something in the setup that could be the issue.

Since we aren’t getting crash reports lets try this…

Go to Security and Maintenance:

Find a instance of a Rhino Crash and view details.

Post a screenshot of the result.

Clean install of Video Drivers instructions.

  1. Perform a complete “Clean” install of the video drivers
  2. This requires selecting “Custom” install on one of the first NVidia install screens. Checkbox “Clean”…check it!
  3. This will completely delete all NVidia driver files, may require a reboot…and then continue to install the drivers.
  4. When the whole process is completed…reboot the machine again.

Already tried with the nvidia driver clean instal, no luck

Faulting application name: Rhino.exe, version: 7.36.23346.16351, time stamp: 0x6579075d
Faulting module name: ntdll.dll, version: 10.0.22621.3527, time stamp: 0x92b2df34
Exception code: 0xc0000374
Fault offset: 0x000000000010c769
Faulting process id: 0x0x1EFC
Faulting application start time: 0x0x1DAA15D28B3207B
Faulting application path: C:\Program Files\Rhino 7\System\Rhino.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 564a9e30-0897-40fe-870a-8ecdee16ef03
Faulting package full name:
Faulting package-relative application ID:

A fairly generic error but does point to repairing your .NetFramework.

  1. Run the combined 2015, 2017, and 2019 installer using this link from Microsoft:https://support.microhttps://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloadssoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads Use the 64-bit tool since Rhino is a 64-bit application.
  2. Run the .NET repair tool from Microsoft:https://www.microsoft.com/en-us/download/details.aspx?id=30135
  3. Repair Rhino 7:
  • Windows Control Panel
  • Add/Remove programs
  • Select Rhino
  • Click Change
  • Click Repair

Hi @Pitti ,
Sorry if I missed this.

  • What happens when you open Rhino 7 in Safemode?
  • Open Rhino normally and type Options. In Options go to → Display and Open GL.
    Drag the slider all the way to the left and restart Rhino,
    Then pick the sidebar. Does it crash?
    If you no, move the slider one step to the right until the crash is back.
    Then return to the previous stable setting.
    Report back.

Thanks,
Mary Ann Fugier

Back to your SystemInfo…
It’s baffling to my why you have both your main and secondary monitors connected to the lesser of your two Nvidia GPUs.
Why?
I would suggest you connect the monitor you use primarily for Rhino directly to the RTX 3090, and the other monitor to the RTX 3060.
Currently, your RTX 3090 is just making heat.
Nothing is connected to it.

So I made all of the net framework updates and rhino repair, I still get the crash.
Also with opengl 1.1 software driver I get the same problem, I also run sfc scannow and dism prcedure to check my system health and there was no issue…

I use my 3090 just for rendering, since that’s my main Job and I need all the 24 gb to be free.
I use the other card to drive my 2 monitors and it worked fine until today…

Hi @Pitti ,
I have the exact same card.
If it happens in Safemode and with OpenGl 1.1, and most of all I (and other readers of this) can not repeat it…
it sounds like a hardware issue.
This is a desktop so you can pop in a new card, even just for testing.

Sincerely,
Mary Ann Fugier

I have 2 video cards:

Video01 is rtx3060 (2 monitor connected in 2560x1440p)
Video02 is rtx3090 (just for cuda/rtx renders)

now I tried to switch the monitors on one or the other and the problem happens anyway.

Fortunately, I only use rhino now to lecture my students (on a laptop) and for some import export of files at work.
The programmes I use daily are stable on this pc (3dsmax + vray + vantage and adobe suite, davinci resolve and fusion).
The only one that is causing me problems is rhino which has always been rock solid, I don’t know what to think…

If you can think of anything else I can try…

Is there scaling applied to the monitors?

Here is the process for creating a dump file if the process is hung.

Once generated zip and send to us via the upload link (bottom of the page)
https://wiki.mcneel.com/rhino/manual_rhino_dmp_windows

If one of these two cards has gone bad, replacing one at a time, with another card is one way to trouble shoot.
Nvidia or other hardware support may be able to test the cards for health.
Again, if it happens in Safemode with no peripherals plugged in, then it is some combination of bad hardware.

No scaling, both are 100%.

Now, after restarting windows a couple of times and pluging back the monitors cables on my 3060 it looks like it’s running smooth, maybe there is some other program that if I am running it it makes rhino crash…
I’ll keep you updated…