Rhino crashes when opening a block to edit it

rhinoformac
blocks

#1

Hi,

I have had consistent problems when double-clicking a block to edit it, Rhino often crashes when this happens. I get around this problem by exploding the block, editing it, then creating a new block with the same name overwriting the old one.

I discovered that when I copy the block into a new document or delete half of the objects in the file I can open it, but I don’t think my file has an excessive number of curves and objects (3092 curves, 109 block instances, 11 hatches). In this file I uploaded I have deleted some objects from the file but Rhino still crashes when trying to edit some of the blocks, though in this file some blocks can be edited with no problem one time, and cause a crash the next time I open it.

I am running Rhino 5.2.4 on macOS 10.12.1, on a late 2013 Retina MacBook Pro.

test.3dm (2.2 MB)


(Pascal Golay) #2

Hi Seeyf - Does the crash occur on double-click, before the BlockEdit ui opens or when you are in there actually editing, or?

Does it make any difference if you run the BlockEdit command rather than double-click?

Does it make any difference if you Ungroup the group that a block instance is in before double-click?

(So far, no problems here)

-Pascal


#3

Hi Pascal, thanks for responding.

The crash occurs both on double-click and the BlockEdit command, before the BlockEdit ui opens. Ungrouping doesn’t make any difference too. I have attached the crash log.

crash.txt (91.4 KB)


#4

Hi Pascal,

Are you unable to replicate the problem at all, meaning all the blocks in the file work ok when you double click them? For me the problem is that I often crash Rhino when accidentally double clicking a block and invoking the BlockEdit command even though i didn’t mean to, so alternatively is there a way to turn off the “double click on block to edit” shortcut?


#5

fwiw @seeyf, i tried your file in the top post and am able to double click-> BlockEdit on all the blocks without crashing.

this is with 5.2.3 on Sierra but i’ll be updating this computer to the latest rhino shortly… i’ll try it again there and report back if anything changes.


[edit]
still working fine with 5.2.4


#6

Thanks for checking Jeff…that is very strange. I tried uninstalling and reinstalling Rhino for Mac and I still have the problem. This seems to be the thread that crashed but I am unable to interpret it, does it give any clue to what happened? The full log is in the previous post.

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x00007fff9d2b0c8a __psynch_cvwait + 10
1 libsystem_pthread.dylib 0x00007fff9d39a96a _pthread_cond_wait + 712
2 libmonosgen-2.0.dylib 0x0000000111c7e874 _wapi_handle_timedwait_signal_handle + 484
3 libmonosgen-2.0.dylib 0x0000000111c8d341 wapi_WaitForSingleObjectEx + 673
4 libmonosgen-2.0.dylib 0x0000000111bf33c9 mono_wait_uninterrupted + 137
5 libmonosgen-2.0.dylib 0x0000000111bf363e ves_icall_System_Threading_WaitHandle_WaitOne_internal + 78
6 ??? 0x000000012f0d9dc4 0 + 5084388804
7 ??? 0x000000012f32d483 0 + 5086827651
8 ??? 0x000000012f0ca4b2 0 + 5084325042
9 ??? 0x000000012f0c9f4f 0 + 5084323663
10 ??? 0x000000012f0c9e76 0 + 5084323446
11 ??? 0x000000012f097372 0 + 5084115826
12 ??? 0x000000012f096915 0 + 5084113173


#7

that’s alien to me… maybe @Dan sees something?


#8

to really get rhino to reset, you have to do a little more than delete files via trashcan.
try resetting as outlined here:

https://wiki.mcneel.com/rhino/mac/resetprefs


(Dan Belcher) #9

Nope, unfortunately, that’s some rather vague system and mono calls, but not enough to work with. In the crash.txt submitted above (thanks @seeyf!), one can clearly see it crashing in BlockEdit. Strange. I would be surprised if this were a settings issue, but it is worth ruling out.