Rhino 6 Crashing Shortly After Opening Any File

I have a problem with Rhino 6 on my laptop. It is crashing whenever I open a file (with or without geometry). I have completely uninstalled and reinstalled Rhino 6 twice and have updated my CPU and GPU drivers so I’m not sure what it could be. It works fine on my desktop, just not my laptop (both are Windows 10).

Please post the text result from the Rhino command _SystemInfo.

Alright here it is:

Rhino 6 SR18 2019-9-23 (Rhino 6, 6.18.19266.14201, Git hash:master @ 3d84f88dec99b2f4e8b7497e739ed2adc2ba8ef6)
License type: Educational, build 2019-09-23
License details: Cloud Zoo. In use by: Weston Hambleton ()

Windows 10.0 SR0.0 or greater (Physical RAM: 12Gb)
Machine name: DESKTOP-0N6RU1V

Hybrid graphics system.
Primary display: Intel® HD Graphics 620 (Intel) Memory: 1GB, Driver date: 9-23-2016 (M-D-Y).
Primary OpenGL: NVIDIA GeForce 940MX (NVidia) Memory: 2GB, Driver date: 9-26-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 436.48

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-26-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - please disable VRay in Options > Plug-ins page and then close and restart Rhino - any different?


Sorry for the delay. I did try to disable VRay, but it doesn’t seem to have changed anything. Rhino still crashes after a minute or so.

Hello - you can also update your Intel driver - it’s pretty old - 2016. In addition, make sure the invidia control panel has Rhino listed as a program that gets high performance.


I feel like this forum should be renamed the “Rhinoceros Please Update Your Video Drivers And If You’re Using a Laptop Make Sure The Nvida Settings Are…” okay it’s getting a bit long.


That looks like it did the trick. I had updated my graphics card, but not the processor. Thanks for your help!