Rhino Crash on New OSX Mavericks (Wenatchee 2013-10-18)


#1

Just upgrade my mac to new OSX Mavericks, and work on my Rhino file.
But seems they don’t really made for each other, and crash every few minutes…

Wonder if anyone has the same experience with me?

Wish you all have a great day/night.

best,
Shikai


(Marlin Prowell) #2

Rhino works fine on OS X Mavericks here.

When submitting crash reports, assume you are the only person having the problem and please carefully describe how we can reproduce the crash. If we cannot reproduce the problem, we won’t be able to fix it.


#3

Sorry about the unclear description.
But the crashes came really random, whenever I draw a line, scale object, it crashes.

The good thing is, when I reinstall the program, it works perfectly again…
hopefully, I am the only one who had this problem.


#4

Same here. I’ve already uninstalled and reinstalled it but it still keeps on crashing after starting to draw a line, curve, circle,…

Cheers
Raoul


#5

Hi, unfortunately I have the same problem, rhino crashes randomly, especially when I scale an object, additionally I started a render in Toucan now which should take me 5 mins, but rhino is showing me that it will take 4 hours, and it seems to be true!!!


#6

and unfortunately running very very slow


#7

After opening an empty file or a file recently, you simply move the view and Rhino closes.


#8

After saving my file in another different name ,the crash problem came back to me again.

It happened when I was trying to rotate my model and check some detail…


(Marlin Prowell) #9

If you are having a problem with OS X Mavericks, be sure to read this. We are not seeing problems here, so we need you to describe exactly how to reproduce the problem. So far, we cannot reproduce any of the problems that are very briefly described in this thread. We need more information. Also be sure to post your OpenGL settings so we can see what kind of computer you have.


#10

Just crash again, I don’t know how to re create the crash to be honest. for me it really comes randomly.

I am using MacBookPro Retina, late 2012

here is Open GL setting.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2013-10-18 (484)
OS X version: Version 10.9 (Build 13A603)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro10,1
Processor: Intel Core i7-3615QM CPU @ 2.30GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 650M OpenGL Engine
Screen size: 1440 x 900
Displays: Color LCD

USB devices
None

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.18.22 310.40.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#11

Simply open a new empty file, use the “panoramic” to move the view and Rhino crashes.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2013-10-18 (484)
OS X version: Versione 10.9 (Build 13A603)

Plug-ins
/Library/ScriptingAdditions/SIMBL.osax/Contents/MacOS/SIMBL
/Users/xxxxxxxxx/Library/Application Support/SIMBL/Plugins/Afloat.bundle/Contents/MacOS/Afloat

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470 CPU @ 3.20GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 680MX OpenGL Engine
Screen size: 2560 x 1440
Displays: iMac

USB devices
None

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.18.22 310.40.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: Nessuno
Anisotropic filtering: Nessuno


#12

Updating: Having again .dmg version 24.09.2013 (481) I installed and worked without crashing.


#13

WOW, my rhino on MAC working very well today, thanks if you repaired something.


#14

After updating to Wenatchee 2013-10-23 (485),haven’t crash even once.

Thank you Rhino :smile:


#15

Hi All. I have been experiencing crashes when I try to" save as". All I have to do is click save as and then click the drop down arrow to select the file type and the program and windows immediately crash. OSX Mavericks seems to still run fine, but if I want to get back into windows I have to shut down and restart. I am running Parrallells’ and maybe that is the issue, although I did not seem to have problems before Mavericks with this. (But did not do a lot of save as either.) I just wanted to see if it was a known bug before I uninstall everything.


(Marlin Prowell) #16

I cannot tell for sure, but it sounds like you are describing a problem with Rhino for Windows and not Rhino for Mac, even though you posted this in a Rhino for Mac thread. Could you please post a screen shot of your Rhinoceros > About Rhinoceros window?

If you are running Rhino for Windows, you should know that running Rhino for Windows inside Parallels is not a supported configuration because of, among other things, numerous display issues.

http://www.rhino3d.com/new/admin#system


#17

Ah yes I did post this in the wrong place, I forget there is a MAC version. I am running windows on a MAC. I think my issue was Parrellels what I did was remove that and reinstall using Boot camp. That seems to have fixed the problem. I’ll just use boot camp from now on. It’s not as convenient to jump in and out of it now especially if I am using it with adobe products, but it’ll have to do.