RHINO 7.11 - mac osx - infinit crash

Hi everyone,

The issue : Rhino was working properly and suddenly started to malfunction.

  • Rhino opens normally (opening panel, ok )

  • When creating a new file or opening any existing one, Rhino automatically crashes.

I reinstalled it but the problem goes on (see attached Rhino crash report).

Do you see any solution ?


Rhino crash report.txt (153.5 KB)


Rhino in use :

7.11.21293.09002, 2021-10-20)

Info OSX :

Catalina 10.15.7

MacBook Pro (13-inch, Mid 2012)

2,5 GHz Intel Core i5 dual core

8 Go 1600 MHz DDR3

Intel HD Graphics 4000 1536 Mo

Hi Albert -
I see that the crash is related to an OpenGL call. On macOS, issues with display drivers are fixed in updates of the operating system. Is it possible to update your machine to macOS Big Sur? If so, I’d make a backup on the Time Machine before updating so that you can go back if necessary.

Apart from that, I just tried creating a new file and opening an existing file on my Mid 2012 MacBook Air and that didn’t give me any issues. Could you post a simple model that crashes on your end, and, also, please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Hi Wim -
Thanks for the answer.

The thing is that right now I can’t even open a new file as much as an existing one. It systematically crashes. It means that I can’t even use any Command or create a simple model because I don’t have access to the soft…

I only can access to the general opening panel and then, what ever the option, crashes when I try to run a new file or any existing one.

MacOS Big Sur is not supposed to run on Mid 2012 macbookPro generation… I’ll see if I can find some patches around but in case, do you see any other possible issue without BigSur ?

I send you the “rhinoceros infos” found on the upper opening panel “Rhinoceros 7 > About Rhinoceros > info >more info…” on the .txt attached. Were you looking for that ?

Rhinocéros Infos.txt (5.4 KB)

The thing I do not understand is that everything was working fine and “suddenly” started to be like described above.

I tryed installing rhino_6.35.21222.17002 and the situation was the same.

I guess the problem is more likely to come from my computer than from Rhino… What do you think and what could be a solution from the report sent ?

Two of our students has the same problems just after installing the latest MacOS update (19H1519) last friday. One of them says Rhino was working before the Apple update without problems.

I would definitely bet on that, without understanding the cause.
Any trick to fix Rhino from your side, apart restoring the OSX to previous version ?

Didn’t talk again with the students, will see them on friday and ask.

Just rebooted the OSX and re install Rhino7, the problem goes one.
Looking forward for any feedback.

Rhino infos.txt (5.4 KB)
Crash report.txt (149.2 KB)

Thank you @user542 and @lemberski we are looking into this right now.

-David

After an other reboot of the MacOS assuring not to do the last Friday Catalina 10.15.7 Security update 2021-007, Rhino 7 is now running without problem !

For now, I disabled the updates to keep on working.

Hope this could help you find what was incompatible between this update and Rhino ! Such a mystery for now…

I have the same issue as user542 after installing the Catalina Security update.
Please update Rhino for this, because I don’t want to downgrade my OS or make it insecure.

@AlexK,

We’re in contact with Apple and also considering making some changes to Rhino to work around the bug while it exists.

Can you give us your Mac model so that we can narrow down which Macs are affected? For example, can you go to Apple Logo → About This Mac → System Report… and paste the Model Identifier here? Another useful piece of information is the GPU in your Mac, which you can get by going to the Graphics/Displays section.

Thank you,
-David

Hi David.

Yes sure. Interestingly, my mac mini has the issue, my macbook does not, both running Catalina with the security update.

mac mini (has the issue):

Modellname: Mac mini
Modell-Identifizierung: Macmini6,2
Prozessortyp: Quad-Core Intel Core i7
Prozessorgeschwindigkeit: 2,6 GHz
Anzahl der Prozessoren: 1
Gesamtanzahl der Kerne: 4
L2-Cache (pro Kern): 256 KB
L3-Cache: 6 MB
Hyper-Threading Technologie: Aktiviert
Speicher: 16 GB

macbook (works fine):

Modellname: MacBook
Modell-Identifizierung: MacBook10,1
Prozessortyp: Dual-Core Intel Core i5
Prozessorgeschwindigkeit: 1,3 GHz
Anzahl der Prozessoren: 1
Gesamtanzahl der Kerne: 2
L2-Cache (pro Kern): 256 KB
L3-Cache: 4 MB
Hyper-Threading Technologie: Aktiviert
Speicher: 8 GB
1 Like

I’m having the exact issue as user452 down to the same computer and everything. I did the supplemental update for Catalina 10.15.7 last night and when I tried to open rhino 7 this morning it would crash upon trying to open any file. I’d hate to have to reinstall an older version of this OS Just to have this program work.

Please help!