Rhino 7 OSX wont stop Crashing- Big Sur

I’m using a 2015 Intel I5 2.5 Ghz MacBook Pro 13, with 16gb ram. About 5 minutes into modeling anything it crashes. It especially doesn’t like any solid editing, and when I try to fillet an edge it’ll crash immediately. I have reinstalled Rhino twice, and have installed the new update today. This new Rhino 7 has made my workflow completely useless. Why is it so buggy? Before it crashes, sometimes I get weird visual artifacts like all 4 views going solid red or pixelated… I don’t get why they would ship such buggy software, almost like they never tested it on real machines. I never had an issue with rhino 5 or 6. Not sure what I can upload to help, i’ve sent in my crash logs every time it crashes (prolly 10-15)

Please run the SystemInfo command and post it.

The 13" Mac have the nearly useless Intel GPU and are not recommended for Rhino.

What macOS are you running?

@John_Brock Running OSX Big Sur. Ive never had issues in the past, so kinda depressing going from Rhino 6 to 7 made it completely useless…
System Info.txt (5.5 KB)

Yes the old Intel 6100s are buggy as hell.
It will be up Apple to get decent drivers working for them.
My 13" has newer Intel 530 and while slow, it doesn’t crash.
I’m running Big Sur too.
This one is on Apple to get fixed.

Sorry.

It comes off weird, it will work perfectly, load quickly, and render fine like my system has the power. But it always ends up crashing during my session like it’s just an unstable build… Not sure why this never presented itself in the rhino 5 or 6, but now in 7… kinda sounds like it might be lazy dev work to just blame on apple. when something has obviously changed on your part when I never had any of these issues a month ago on rhino 6.

I don’t see that you have sent in any Rhino crash reports.
Why not?

Maybe roll back to Catalina?

I submit them every time it pops up. I would roll back, but that would take a few hours of work to reinstall the operating system and transfer everything back… at that point I’ll teach myself solid works. Ive always loved rhino, but this is the buggiest software I’ve ever used.

Just crashed and sent you another right now.

It will take some time to upload the crash dumps, evaluate them, and post it where I can see it.
Probably tomorrow.

If you do a Google search for Intel 6100 Big Sur crashes you’ll see a lot of information.

The crashing is in your Duet display.
This fits with the Google reports I’ve been seeing with the 6100.
Disconnect your iPad and run Rhino on just the native display.

Any better?

My iPad wasn’t plugged in when I was having that problem. I just uninstalled Duet and am still having the visual artifacts and crashing. Do you know anything else I could try?

I don’t.
Did you send inn the new crash report with Duet removed?

1 Like

Yes, I just sent it in. For the first minute I open the model it works, but then after a few changes it starts to glitch out. The layer visibility and the lines keep getting messed up, i’ll post a screenshot the next time it happens.

here I have the view as shaded, but all of a sudden it changed so some of the model is wireframe only. other times one of the views goes red. I have also had it go solid and then the lines are no longer viewable or selectable, you just see the rendered object.

Seems even more unstable today, I sent in 5 or so crash logs

Try this please:
In Preferences > OpenGL, set your Antialiasing to None, Quit, and restart.

Any better?

1 Like

I thin that might have been the Issue! 20 minutes in and it hasn’t hung with the beach ball or crashed yet!

Thank you for the help and the time. I don’t do any complex rendering so I have never been limited by not having a GPU. I mainly do product design and things that will be CNC milled or 3d printed. Looks like this computer will last me a bit longer

I’m using Rhino since 2015 on different Mac computers. Using on Catalina worked perfectly. Just did a clean install (erasing totally the hard drive before installing the new OS) and installing Big Sur for the first time yesterday.
I installed Rhino 5 (5F96) and opens. If opening a file it crashes and quit. I can’t access preferences (it crashes). I tried opening old files or starting from blank page model. Same results.
I’ve an iMac Retina 5K, 27-inch, 2019, 3,6 GHz 8-Core Intel Core i9, 80 GB 2667 Mhz DDR4, Radeon Pro 580X 8 GB
Rhino 5 works for me I don’t really need to upgrade. Does upgrading would fix the issue?
Thank you.

Hi Gil -
Running Rhino 5 on Big Sur is not supported.
Your options are to roll back to Catalina or to upgrade to Rhino 7.
-wim