Rhino Closing While Trying To Open Files

Yes it does as far as I know.

Thanks, that means it’s file-specific.
When you launch Rhino, create a simple box in a factory-default template and save that file to your desktop, does Rhino have problems opening that file again later?

That worked well!

What happens when you disable the Lumion plug-in, restart Rhino, and then try to open one of your other models?

1 Like

It still closed. First thing on the command line was Blocking Lumion Plugin. Not quite the exact words.
Here is another screenshot before it closed.

Ryan, Can you ensure that your using the Nvidia card per these instructions? Thanks.

Looks like it
Screenshot 2022-12-05 110811
Screenshot 2022-12-05 110833

1 Like

Hi Ryan -
Can you post or upload (Rhino - Upload to Support) a file that makes Rhino close?

Here is a file. I wasn’t sure where to find your email so I’ll just post it here.
It didn’t seem to matter what file I opened. :confused:
12 by 16’ cabin with 8’ addition and loft.3dm (19.9 MB)

I have since a few months the same “problem” but not always and only the first time I start Rhino. I am using V6

My Sys info
Rhino 6 SR32 2020-12-5 (Rhino 6, 6.32.20340.21001, Git hash:master @ f0da95af49009959d0100568acb11aea288bcea0)
License type: Educational, build 2020-12-05
License details: Stand-Alone

Windows 10.0.0 SR0.0 or greater (Physical RAM: 24Gb)
Machine name: FRITS-LAPTOP-HP

Computer platform: LAPTOP - Plugged in [96% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 530 (Intel) Memory: 1GB, Driver date: 10-17-2017 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 960M (NVidia) Memory: 2GB, Driver date: 9-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.19
> Integrated acclerated graphics device with 1 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-23-2021
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.32.20340.21001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.32.20340.21001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.32.20340.21001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.32.20340.21001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

Mine seems quite random, like not just at startup. Sometimes it works sometimes it doesn’t. Even between switching files it will do it. So confusing :confused: :man_shrugging:

Is that what you were looking for?

@wim @Japhy
Well just an update. The problem seems to have stopped so all good for now. Thank you all for your help!
:smiley: :+1:

with my version it still the same.
when open the first time and selecting a file from the recent files, Rhino is closing and I get a rhino error reporting message.
It only occurs the first time rhino is opend after a new windows startup.

Hi Frits -

When that crash reporter appears, please send it in. I’m not seeing any reports from your eMail address.

Apart from that, please update to Rhino 6.35, which is the latest version for that release.

Wim, the error report was send 17 min ago but the postoffice is probably busy with christmas wishes. :smiley:

Thx for your suggestion to update. I did not know there was one.
Greetings Frits

After installing build 6.35 it seems to be solved.
also the asking to save a empty file did not happen.

Wim, thanks !!!

Wim the problem still excists hereby I send the crashdump

RhinoCrashDump.3dm (10.5 KB)

@Frits1956 that is not the crashdump we need. It is the file written out with Rhino data at the moment of the crash. The crashdump will be named RhinoCrashDump.dmp (take note of the extension .dmp). This file you can see on your Desktop before you close the error reporting dialog.


Now I did not send the dumpfile with the popup so the file did not disappear and I was able to mail it to this post. Hope it is ok now