Rhino always create mesh when display them

Hi all,

I’m an old Rhino user (from many many years…) but new (few months) to rhino 5.

I’ve found an issue that is really annoying: when I’ve a lot of objects hidden and I’m working in wireframe/render mode and I decide to show all, Rhino always do a “creating meshes” to let me view render or shaded view. On a very complex model (4-500 mb model) this can take SEVERAL seconds (like 15-30) on a dual CPU Xeon machine… And this takes several seconds also because for a mysterious reason the CPU usage of rhino while create meshes never goes over 10%… While I’m looking the monitor waiting.

Now this is something I use to do many times while working: hide all except what I’m working on, modify it, show all and render viewport, So this problem is for me really annoying!
Moreover this happens not only on 3d models created from scratch on R5, but also on 3d models “born” in rhino 4 where this issue were not present at all.
This also happens on both our machines, both running R5. Two identical machines, dual Xeon with two Nvidia 970 in SLI mode.

Is there a solution? Anyone having the same issue?

Thank you all,


Hi Tommaso - if you Show everything , Zoom Extents, and Shade the view, wait for the meshes, then hide objects, work in wireframe, and then show objects, do you still see the meshing operation?


Isn’t that an issue of having too many “Display” items selected. Also, your computer is a bit long in the tooth. I find a minimum 2 Gigs of video Ram for good fast rendering;)

First thanks a lot Pascal!!!
Pascal yes. Rhino has to recalculate the meshes EVERY time I show something. I did more tests yesterday and if i’m showing one surface in render mode, than I pass to wireframe and then I do a show all (or a show selected) Rhino says “creating meshes”. Also if I do a Zoom extents to let is calculate ALL the meshes, it doesn’t matter, every time has to recalculate them.
I don’t think he’s recalculating ALL the meshes, but still I’ve to wait 15-20 sec on a big 4-500 mb file.

Thanks to you too, John!
The issue is also that the CPU is not really helping the “calculate meshes” process. I think that the calculation of the meshes is something up to the CPU, the display of them is up to the GPU. But normally the meshes are calculated one time and saved into the file, and not re-calculated every time you display them!
Our PCs are 5 months old, equipped with a dual Xeon and TWO 970 GTX with 4 gb each… So I was really expecting to FLY over the calculations and not staying in front of my monitor looking the small circle to turn…
The problem is that while Rhino is processing the “calculating meshes” the CPU is not working at all (10% MAX on an average of 7-8%), so I don’t know what to do…

EDIT: I did a research and the fact that Rhino is using a small fraction of my CPU is normal… Apparently Rhino is NOT multithread, so I did (the IT manager did in reality) a mistake to by a multi cpu PC. A single CPU with equivalent power it’s better… After all this years of using Rhino I didn’t know that…

Hi Tomasso - Extrusion objects are meshed on the fly - these are new in V5, so it seems at least possible that this is what you’re seeing… but the meshes on these should be calculated pretty much instantly - you would need a very large number for it to be noticeable, I would think, and I don’t know that they are recalculated just with Hide then Show - as far as I can see it does not… If you start a new file and add say an array of many boxes - do you see this same problem - any sign of meshing on the command line?

Are there bad objects in your file? (SelBadObjects)


thanks again @pascal,

No bad objects in the file.
I’m a yacht designer and the 3d file I’m working with are boats, so not so much extrusions…
BUT i did an array with 50x50x50 cubes and… No problem. I can hide, show or whatever, Rhino was never re-calculating meshes.

So there is a problem on our files, something recurring and that was not present when using V4. Some files comes from V4, some others are made in V5 (but there are some objects copied from V4 files) but all OUR files have this issue. Really I can’t understand… And it’s really annoying…

Hi Tomasso - can you use layers to try to isolate the object(s) that is causing this, possibly? If you turn off half the layers and the problem goes away, then the problem is in the other layers - half again, etc etc - maybe we can locate the problem.


I’m trying but… pratically 80% of the objects in the file are re-meshed. Just some of them are not affected by this issue. Brief, it’s easyer to isolate the non re-mesh objects than the others.
I really don’t understand, some of them are simples geometries, like this one, made only by planar surface with a constant fillet:

I’m getting crazy!

Hi Tomasso - if you export some of these to a new file - does the same problem occur? If so, please send me some, via private message.



I loft a lot of Hulls. All the Hulls I make unfold to be made into Paper models. that really sets up some limitations working with Rhino, and forces you to be careful with what your making. I would recommend not using the “Planar” method. Make the basic shape, the Extrude the part. You can easy “Patch” or “Cap the Planar Holes” for a surface.

Sample of boat hull I made.