Creating render mesh for rendering only? Why is the shaded display mode mesh not enough?


I have complex model and the shaded display looks fine, anything is within the viewport area. But if I press the render button, than a long render mesh creation is started. Is this right? Is the render mesh not created for display before?


That doesn’t sound right, no. Are you using the default Rhino renderer or some plug-in?

I use Vray for Rhino.

Does it happen with the built in renderer?

No, its a vray thing, i know about this, what you should do is tick save render mesh and blaba in autosave file if im correct,…

Good to know, thank you.

I will send a bug report ticket.

i spoke to one of the vray guys, i think they said its not a bug,…

Do they call it a feature? No, it’s a bug, for my complex models I can’t wait for minutes to get the render mesh redone. I sent a bug report ticket.

I am guessing you either disabled “Preview custom render meshes in viewport” under the Rhino Rendering settings, or you had geometry outside of view port that still needed to be meshed (Rhino only meshes things visable in the shaded viewport). Without seeing the model it is hard to say. It appears to me the “Preview custom render meshes in viewport” is broken in SR10, maybe someone at McNeel can weigh in on this.

The option wasn’t disabled here and also the whole scene was visible at the viewport. Today at my current project I havn’t seen the behavior. I will try to find a scene where it can repeat the problem.

Do an incremental save, close the file and render it again, then if im correct it should reoccur,…

Hello @Micha , Have you resolved this problem? I am seeing the same thing here. Preview option is enabled and shaded mode shows all objects but each time I render I get a long [Creating Render Meshes] wait with Vray asif the current meshes are either being recalculated or redone with some other misc. settings. Michael VS

Please do not confuse external render engines such as VRay and Maxwell with truly integrated render plugins like the Rhino default renderer or Neon or whatever.

Although they come as plugins, they are just a UI-Plugin with an external engine. So whatever Rhino render mesh there is, is generally not in a compatible format for the render engine to use. The output “creating render meshes” may be just a short hand for the “converting the rhino render meshes to our own mesh format”. Depending on the complexity of your scene, this may take some time.

Then again, there may be an option to specify custom meshing parameters for the renderer. In that case, the meshes would be recalculated on export, but I doubt that.

In VRay For Rhino we receive our meshes from a overridden function CRhinoSdkRenderEx::AddRenderMeshToSceneEx and in the case of blocks we need to call RhinoGetRenderMeshes( to get the correct information. After receiving the meshes from Rhino we do very little processing on the mesh information, no where in that processing do we print “creating render meshes”. I am assuming this is very similar method to what Rhino Default Render and/or Neon use.

Hello @matt_newberg & @Micha , I have been testing this with the various suggested settings above and also some other attempts at changing other possible settings like the Neon Adaptive sampling but rendering to Vray still behaves this way. Sofar I have figured out:

  1. The exact wording of the command line response is"Creating rendering meshes… Press Esc to cancel"
  2. I have tried ghosted view to before each test to make sure all viewport meshes have been created.
  3. The “Creating rendering meshes… Press Esc to cancel” does not appear once. If I look at command history for my current model it displays this message to the command line about 50+ times before Vray commences rendering.
  4. Meshing only seems to happen the 1st time. the 2nd and 3rd render from other positions go straight to render.
  5. This is a copy of my command history info.
    As you can see the Re-meshing occurs after creation of the Geometry Table begins.:

Command: _render
Processing light table
Processing geometry table
Creating rendering meshes… Press Esc to cancel
Creating rendering meshes… Press Esc to cancel
Creating rendering meshes… Press Esc to cancel
And then the above line repeats about 50+ times on and on…

Does this give anyone any ideas of how to prevent this re-mesh and rather make use of the existing viewport meshes as they are? Michael VS

The last weeks I enabled this option and I haven’t seen the problem anymore. Today I disabled the option, but no problems yet. I don’t know why I don’t see the problem anymore, but maybe my current project doesn’t trigger the bug. I will observe it.

SOLVED! - At least on my end…
The problem seems to have to do with Save Small.
I work with large models with many iterations so I am in the habit of using the Save Small option most of the time.
I didn’t think this was a problem since Rhino creates new meshes upon opening the file anyway, but apparently it does make a difference.
Render Re-Meshing does not occur if a file was saved with the normal Save option (Which thus includes all the meshes in the file)

I thought it might work as well if a file which was previously saved with the Save Small option, is first saved (normal option) and then rendered, but this didn’t work either and it still re-meshed.

Opening a file which was previously saved using the save small option and letting Rhino viewport re-mesh everything does not seem to register with Vray or Rhino that the meshes already exist so it redoes the process.
Even if I open a file which was saved using the Save Small option and Save normally with all the current meshes into the file, the re-mesh still occurs.

Conclusion: The Meshes need to be saved into the physical Rhino file before opening the file to prevent the 1st Vray render doing the “Creating Meshes…” wait.
It seems asif meshes created from scratch when opening the file are ignored.

My Test: 1. Save Small, New File, Open file again in Shaded or ghosted mode, Render (Remesh happens)
My Test 2: Save Normally, New File, Open file again in Shaded or ghosted mode, Render (No Remesh)

Not much I can do about it because I don’t want to fill my HD up with huge meshed files(Normal Save), but at least I know how to avoid it if I have to.
Perhaps @Micha can confirm this is what is causing this on his end too. Michael VS

Render meshes are not (necessarily) the same as the shading meshes.

Hi @Marc Ok. Yes. I can understand in the case of displacement mesh generated by the renderer on the fly but…
Are you saying that when you save normally that Rhino is saving the viewport meshes + Render meshes in the file?
And if so, then why do we bother setting up the viewport meshes at all?
And why are they called Render Meshes in Rhino if they are not actually render meshes?
@matt_newberg 's comments above seem to indicate that Vray uses the meshes that Rhino uses.

Michael VS

Reading up on your previous thread, Menno seems to suggest that there is a difference between the render mesh and the viewport shading mesh.

So if by default the render meshes are not generated for viewport shading, they will only be generated once you start to render. Then they can be cached and reused for the next render. If you save a large file, they are stored in the file. If you save small, they are thrown away. That’s basically, what you have seen.