Rhino 8 v. slow save

Are there any fixes for slow saving in Rhino 8? I have a brand new beast of a machine, huge nvme drives, all my other apps save extremely quickly and fast (photoshop, meshmixer, Zbrush, etc. Why is Rhino taking forever to save a 300MB file??
Extremely unpleasant working on rush deadlines with this issue.
Please fix, thank you.
Robert

1 Like

Would you be able to share you machine specs and provide the file so one of our developers can test?

Turn off the default file ‘compression’. The ppl in charge think it makes more sense to have it on (by default), but it doesn’t – harddrive space is cheap in the 21st century. It only causes everyone to think the new Rhino’s are slow, and no one ever says anything about the silly secret hidden default ‘file compression’ obstruction – you have to dig to find the secrets, for some if not most, it took yrs before it was discovered. Imagine all the time that was waisted saving files and twiddling thumbs, and thinking the new Rhino’s were slower than the old Rhino’s.

Imagine all the users that gave up on the new Rhino’s, that didn’t realize it was some hidden setting somewhere that was the culprit the whole time.

Imagine all the harddrive space that could have been purchase cheap to compensate for the lost time waiting for saves.

File compression should be off by default – period.

Make sure this is unchecked:

If you run out of harddrive space, just buy more. Time is money.

1 Like

@carvecream does this fix it for you?

Very slow when file compression is enabled

1 Like

Disable it. For the most part, unless your disc space is very limited, there is no reason to have it on. This is not a V8 problem, it was already true in V7.

1 Like

Does this option actually hooked in Mac R ?
it is there in advance, but I disabled it [did a rhino restart made a small change and resaved
file size remains the same. [it a big file]

  • didn’t actually see a noticeable lag in saving, but I do have a long wait when rhino open the file.
    [wishful thinking about it having to do with the decompressing …]

thanks
Akash

oh good lord how did I not know about this all these years. crimminy.

but hilarious that it takes 4 minutes to compress a 900mb file to 500mb, that’s seems broken in itself!! :slight_smile:
but i’m now very happy with fast saves. Thank you @lander and everyone else.

-Robert

1 Like

Yeah but V8 turned it back on, so glad I stumbled on this thread cause it shoulda been off already :sweat_smile:

1 Like