Rhino 8 upgrade not loading/responding

I’ve updated my licence key, uninstalled Rhino 6, opened Rhino 8 in safe mode and disabled all plugins, but my Rhino 8 still freezes just when it looks like it’s loaded. I’ve previously had the trial version running fine. Here’s my System info:

OS Name Microsoft Windows 10 Home
Version 10.0.19045 Build 19045
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name MOIRAPATIENCE-M
System Manufacturer ASUSTeK COMPUTER INC.
System Model GL502VMK
System Type x64-based PC
System SKU
Processor Intel(R) Core™ i5-7300HQ CPU @ 2.50GHz, 2496 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. GL502VMK.308, 03/05/2019
SMBIOS Version 3.0
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product GL502VMK
BaseBoard Version 1.0
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume2
Locale United Kingdom
Hardware Abstraction Layer Version = 10.0.19041.3636
Time Zone GMT Standard Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.96 GB
Available Physical Memory 2.42 GB
Total Virtual Memory 23.0 GB
Available Virtual Memory 14.0 GB
Page File Space 15.0 GB
Page File D:\pagefile.sys
Kernel DMA Protection Off
Virtualisation-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualisation Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Hi Meg, Can you reinstall 6 real quick & run systemInfo?

What display adaptors are you running? (systeminfo will provide more details)

Lets try creating a shortcut with the netfx flag in the shortcut to eliminate an old Rhino 6 plugin interfering. If unsuccessful remove the /netfx flag after testing.

To start Rhino in .NET Framework once:

  1. Create a new shortcut for Rhino in Windows
  2. Edit the shortcut
  3. Add command line argument /netfx

image

Adapter Description NVIDIA GeForce GTX 1060

I’ve uninstalledRhino 8 and installed Rhino 6 again and now it’s also playing up. I tried the /netfx addition to a shortcut but Windows won’t let me apply it

update: I ran “C:\Program Files\Rhino 6\System\Rhino.exe”/netfx through the run command and it tried to open but froze again

That flag is only for Rhino 8

Lets repair your Microsoft Redistributables

the x64 is what you want

done that. Rhino 6 still froze. Have uninstalled 6 and reinstalled 8 (fresh download) and tried the /netfx shortcut but had the same problem. Rhino 8 still freezing on startup.

Are there any errors shown?

Something is wrong with your Windows, is it fully up do date? Do have a aggressive virus protection software installed?

I would focus on the Rhino 6 install first, less variables.

is this a laptop with a hybrid graphics system?

here is a microsoft .net repair tool
https://www.microsoft.com/en-us/download/details.aspx?id=30135

I’m back with Rhino 6, have updated my graphics card driver, run a virus scan (all clear), and run the .net repair tool. I didn’t think this was a hybrid but have been through the guide and set Rhino to default to the highest performance option (though both options say the same GeForce card). Rhino 6 still freezes when trying to open a file I was successfully working on this morning before trying to upgrade to 8.

Thanks, please run SystemInfo in the Rhino command line and paste your results.

Rhino 6 SR35 2021-8-10 (Rhino 6, 6.35.21222.17001, Git hash:master @ 073ac7b225c67348731c6597127b9410126c3139)
License type: Commercial, build 2021-08-10
License details: Cloud Zoo. In use by: Meg Walker ()

Windows 10.0.0 SR0.0 or greater (Physical RAM: 8Gb)
Machine name: MOIRAPATIENCE-M

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: (null)
> Integrated acclerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 2-15-2024
Driver Version: 31.0.15.5161
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.35.21222.17001

This via safemode? Rhino 6 won’t open normally?

no it freezes before opening

this is what I get to but it’s not responding

The video card is having issues. A clean install of the NVidia drivers is recommended first, then try older drivers (with clean installs each time)

To clean install a nvidia driver choose Custom install and enable the Clean Install checkbox.

hang on, I just tried removing my second monitor and it’s opened ok! could that be the problem somehow?

I’m going to do this anyway

Yup! getting closer, could be something physical about the port or how the driver is reading the monitor.