Rhino 8 BETA feedback

Hello,

Here is my report after testing Rhino 8 beta for a few hours
(tested using Rhino v.8.0.23255.13164, 2023-09-12 on a MacBook Pro M1 / MacOS Monterey).

In general, I am totally blown away by Metal performances!
I have no memory of Rhino working THIS well on a Mac before, thank you very much McNeel!

Anyway, here are some issues I found in this version:

1. Resizing containers/toolbars (when they are not floating windows) is pretty hard and the click-and-drag is not always working

2. The info panel (bottom-left on the screen) pops-up too slowly
For example, If I use the Distance command, I have to wait almost 2 seconds to read the result of the operation. I find the animation pretty useless and distracting, can we turn it off or at least speed up the pop-up?

2. popup

3. Rhino does not remembers exactly the Window Layout when quitting and re-launching the application
Here below an example where it randomly added a new container.

4. The “Dynamic Highlight” function doesn’t turns off when disabled from Rhino’s preferences

5. “Section Style” function and its customizing window are pretty buggy.
I randomly cannot click on menus to customize it, it randomly loses the saved settings or just doesn’t work.

6. Right-clicking menu on a viewport doesn’t have all the options as in Rhino 7. Is it possible to have them back?

7. The toolbar’s tabs titles are way too “pale”, as if they where disabled

8. Lines display often with random thickness, depending on the zoom level of the view.
Here a view in Shaded mode (where I set the edges lines at Scale 1) before and after zooming in in the viewport:

9. Monochrome has glitches (and also, its lines are very low-quality)

10. Rhino’s GUI has never been “swiss” (if you know what I mean), but I have the feeling that it’s become worst with 8.
The alignments of almost every element of the GUI look… very random. Here are some examples:

11. The flair menu should be disabled?

Capture d’écran 2023-09-13 à 16.43.39

.
.

I hope those issues can be solved during the beta development?
And the GUI refined a little bit… :slight_smile:

Cheers,

A

4 Likes

yeah, I said something about that before too.

Apparently, it works like Windows now in that in order to get the old context menu upon right-click, you have to right click on the viewport title

personally, I didn’t really like the new way so I made a macro to bring up the viewport options and make selections via keystroke now… ymmv

+1 regarding the animated popup for things like _Length and _BoundingBox and _Distance… I too would rather that be an instant message or something we can control the speed of

2 Likes

Oh no! This is a big step back!
Please McNeel bring the contextual menu back :frowning:

1 Like

Also, selecting objects from the pop-up menu doesn’t work…!

selection

wacom can’t rotate view right and left around object like in 7

where is the command editor?

No comments at all on those bugs / request?

1 Like

Can you point me to the exact setting in Rhino that is not working for you?

You will need to be more specific for this, because here I’m not running into any issues with the section styles dialog. If possible also send a model that shows the issue.

@the_eraser can you reset you Rhino 8 to factory settings with the _Reset command and see if any of the display issues you are experiencing resolve?

If you have any customizations made like aliases or keyboard settings, make sure to back these up first.

4 posts were split to a new topic: BETA fails to update

The command prompt remains static and can’t drag anywhere.
I can make it bigger or smaller but won’t let me grab it.
if I open a new file then I can grab it and move it.
But I can only move once then goes back to static.
I also feel like this command prompt is too big and takes too much room in the screen.

I saw it has been solved in the new beta :slight_smile:

This is the option that won’t turn off when disabled (Dynamic Highlight):

Nothing changed after the _Reset command, multiple models that I’m working with keep displaying badly.
Here is one example (shaded mode):

And here is another one:

If you could send me the models, I would love to take a look and see if we can tune this up.

MP’ing you. Thanks

@Gijs here is a video for this one:

A post was merged into an existing topic: Coordinates in statusbar update slowly

could it be that you have turned off Rhino.Options.ChooseOneObject.DynamicHighlight?

Yes, you’re right, if I turn it on it works.
So, how to turn off just the new mouse-hovering “dynamic highlight” and still able to select objects like before?

(I mean, I like to have it behaving like Rhino 7:
that it just appears AFTER cmd+shift+click to sub-select, not before the click.
The reason is that i always have cmd+shift pressed while browsing my models, because it’s also the keys that used to orbit around an object in combination with mouse right click by default)

With less words: can it be disabled with mouse-hover and act just like before?