BETA fails to update

Don’t know if this is the right thread, but this weeks Beta (Windows) did not automatically download, and when I manually downloaded and tried to install it I got Defender popping up saying it prevented it from running - so I had to hit “More Info” and “Run Anyway” to get it installed.

Also it took a long time to initially load, maybe 15-20 seconds with the spinning blue circle before I got the the “Updating Toolbars, etc…” message box.

Same for me on both my personal and work laptops.

And, on my laptop, which had the previous weeks Beta, I opened it, went to Updates and Statistics and it said it was downloading a new version. Waited awhile, closed the Beta, but no “New version ready to be installed…” box popped up on the screen when I closed it. Reopened the Beta and still no “New version ready to be installed…” message, and going to updates/statistics, it then said I had the latest (last week’s, 12 september) version installed… :roll_eyes:

Ended up re-downloading from the “check now” page and installing (same Defender block also).

Looks related to the problem I previously reported, except I do no get the opportunity to see “Run Anyway”. The download is just canceled.

This is a sad reality right now due to new code signing certificates. We’re working on improving this for next week or the week after.

The latest Beta seems to have fixed the problem, it auto-downloaded here today.

1 Like