Rhino 7 won't print (Betcha never heard THAT before!)

For some time now, Rhino 7 fails to print. I think this has been a problem for most of the time I’ve had V7, but I can’t attest to that. I’ve updated my video drivers. I’ve tried print different display modes.
I’ve tried different printers and different print drivers, but to no avail.

Below is the system info file (as I frequently see that people are asked to provide this in similar situations). There are a few lines suggesting I switch which of my monitors is primary; I have not done this as I can’t see how doing so might help.

Any help or suggestions from the community? Thanks, in advance.

  • Patrick


Rhino 7 SR21 2022-7-27 (Rhino 7, 7.21.22208.13001, Git hash:master @ c31aea87137a5d0de449338a7ef6856f49dd4797)
License type: Commercial, build 2022-07-27
License details: Cloud Zoo

Windows 10 (10.0.19043 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-3-2022 (M-D-Y). OpenGL Ver: 4.6.0 - Build
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 7-21-2022 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0

Desktop is using the slower, less reliable integrated graphics device and probably needs a configuration change.

An accelerated graphics device exists and is attached to a monitor, but it’s not being used by Rhino.

  • Recommended: Use Windows’ Display Settings to configure the monitor attached to the NVIDIA GeForce GTX 1070, to be the “Main Display”.
  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build
Driver Date: 2-3-2022
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

Can you print to a file (i.e. PDF) ? Do you get anything when printing to the Rhino PDF printer driver?

Can you share some screenshots of your Print dialog with the settings you are using?

Are you able to print with vector output?

I see that you are on a desktop but the condition is similar, your OpenGL is set to the smaller video card, typically this would be on the nvidia

That section in SystemInfo should have set your hair on fire…

Curious, what does the display have to do with failures to print?
(unless we’re talking about screen captures of pixels I guess)

Printing and display drivers have always been closely coupled in Windows. Probably on Macs too.

Raster printing is closely coupled with display drivers on both Windows and Mac. Vector printing is not coupled with display drivers.

Can you print to a file (i.e. PDF) ? Do you get anything when printing to the Rhino PDF printer driver?

Can you share some screenshots of your Print dialog with the settings you are using?

No. I’ve tried every printer I’ve got to no avail. I’ll post some screenshots.

Thanks for the reply.

Unfortunately, no. I’ll post some screenshots of my print settings. Thanks for the reply.

Only a small grass fire, due to the fact that I didn’t quite see how the display driver could mess up the printing. Do you suggest there might be something I should do with that info? …Maybe shut off my main monitor and open Rhino on my 2nd monitor (Yeah, that sounds goofy even to me)

Oops, I just realized I’ve been posting replies to individuals, install of mass-replying. Sorry.