Rhino 7 slow and not responding

Have been using Rhino 7 trial for about 8 weeks now and it was fine until yesterday. Suddenly it became slow and sluggish and then just not responding. I have turned off all unnecessary layers. Turned off GPU. Switched to wireframe view ( I’m only 2d drawing anyway.)
And am getting these yellow drag lines when copying and pasting things- see pic below.
i have updated the graphics card yesterday but that hasn’t helped either. Unfortunately i deleted rhino 6 on my computer as i thought that may have been the problem but made no change.
Below if the system info…
Rhino 7 SR2 2021-1-12 (Rhino 7, 7.2.21012.11001, Git hash:master @ 2f08cf516ffc716c4c4a369abf7625798ef79bca)
License type: Evaluation, build 2021-01-12
License details: Cloud Zoo
Expires on: 2021-03-16

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P4000 (NVidia) Memory: 8GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
Microsoft Basic Display Adapter (Microsoft) Memory: 0MB, Driver date: 6-21-2006 (M-D-Y).
> External USB display device with 0 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version: 27.21.14.6140
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\NamedPositions.rhp “Named Position”

1 Like

Hi Marc

meaning what, exactly?

Is the problem with a particular file or any file? If you start Rhino and make a box, does it behave as you expect?

-Pascal

seems to be just the one file. Yes opening a file and drawing a box works fine.
when opening the file. it will work a while ( 5- 10 mins) then will start to slow down and not respond. Trying to copy and paste seems to aggravate it as it then gets lots of yellow drag lines like I have pastes it over and over dozens of times. After that it will stop responding all together.
By GPU I mean I mean options- view- OpenGL- GPU. I was informed this might help. It hasn’t.

Hello - can you please send us the file at tech@mcneel.com, along with a link back here to this topic in your comments? If the zipped, SaveSmall file is very large, please upload to www.rhino3d.com/upload to my attention.

-Pascal

the same here
i am using
Version 7 SR5
(7.5.21068.13001, 2021-03-09)
Commercial

Copy / paste… selecting… undo… its kind of pain compare this with old Rhino 5 smoothness

Hello - in your case, is this problem showing up in particular files, or in any file, even a new one?

-Pascal

Even in new clean file.
It happens even with simple selectin lines or a small curve.
But undos and copys with even with small objects, like boxes are sluggish.
One thing i can say is Rhino 7 feels more slow compared to Rhino 5

I still have very slow selection issues with V7 in large scenes…

in fact it is very obvious in small scenes (24mb), if I open same file in v6 & v7 and just start selecting objects, it is instant in 6 and 7 there is an obvious lag

here is a link to a simple movie i took on my phone… showing how painful selection is in V7

Hi Rich, that is pretty hideous - can you tell me what panels, if any, are open (Properties, Layers, BoxEdit, maybe?)

-Pascal

No panels open.
I would be more than happy to give you remote access to my pc if you wanted to dig around??

Rich

Rhino 7 SR4 2021-3-19 (Rhino 7, 7.4.21078.01001, Git hash:master @ a432d22ab7f0f7b53d157d578278070c8bf6eff4)
License type: Commercial, build 2021-03-19
License details: Cloud Zoo

Windows (Physical RAM: 16Gb)
VersionMajorMinorServicePack failed

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 SUPER (NVidia) Memory: 8GB, Driver date: 2-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.72
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
Intel(R) HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 8-4-2015 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-23-2021
Driver Version: 27.21.14.6172
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\Richard Follett\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Lumion LiveSync for Rhino (839d6175-32d1-4ffe-a0a4-b7fb43cf0ff5)\2018.10.30.683\Lumion\Rhino 6.0\LumionPlugin.rhp “Lumion LiveSync for Rhino”
C:\Users\Richard Follett\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\1.0.0.0\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Rich - I think we may have tried this but if not can you please disable these plug-ins in Options > Plug-ins page and then close and restart Rhino:

Lumion LiveSync for Rhino
KeyShot9RhinoPlugin

It may be that a developer will need to poke around on your machine - lets make sure the plug-ins are not involved first…

-Pascal

hello Pascal
and thank you for your help with this issue.
I disabled both plugins and restarted V7 , I can see plugins where disabled …
But I am afraid still very slow…
So if a developer wants to take a look
thanks
rich

@rich - your intel driver is very old - can you update that to the latest from the Intel website and see if that makes any difference?

Also, can you take a screen shot of your entire Rhino screen when the slowness is evident, and post here or send it to me on tech@mcneel.com?

-Pascal

One other option to consider; since you are correctly not using that old Intel GPU, is to Disable it in Windows Device Manager > Display adapters.

I have done this myself on my own Desktop computer.

1 Like

I presume you mean the driver for the Intel GPU ? If yes then I disabled it like John Brock suggested… Made no differance in speed selection. Sorry…

Same here.
Even with simple lines.

Hello, same here, slow selections between objects and copy/paste on multiple lines very slow.
Also the _Options command takes few seconds. The slow behaviour is before fire the command, moving the object is quite smooth.

Now I will revert to a previous version of Rhino7. Rhino 5 on the same file is A LOT, I mean A LOT, more responsive and as expected.

I’m posting the systeminfo:

Rhino 7 SR5 2021-3-9 (Rhino 7, 7.5.21068.13001, Git hash:master @ 76e41732e41ab44776e5ac3fa043f38d54440011)
License type: Commerciale, build 2021-03-09
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3090 (NVidia) Memory: 24GB, Driver date: 3-11-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.92
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-11-2021
Driver Version: 27.21.14.6192
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 24 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21068.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21068.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.5.21068.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21068.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21068.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”
C:\Users\apola\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2020.12.9.865\PanelingTools.rhp “PanelingTools”

EDIT: further troubleshooting reveal that the major slowdowns are expeceted when selecting multiple lines, a not so complex 2d drawing. Using the boxedit to edit the position of the selected lines the program become unresponsive and hang indefinitely (after 20 seconds I shut down the process).
I repeat, same file in Rhino 5 no problem at all.
Thank you.