Rhino 7 says it requires a license to run and closes when I have license

I recently linked a license key to my rhino account.

I’ve been loading up the program and logging in, and when I type my email address, it says there is a license found for my account. Then I’m taken to a web browser saying if I allow rhino to view my basic information, name etc., and when I click allow, I get a pop up sayin that rhino needs a license to run and will now exit.

I’m not sure what the problem is, and I’ve reinstalled rhino 7 and it’s still doing the same thing.

Hi Isaiah -

Are you trying this with the current 7.13 version or an older version that you downloaded previously? Make sure you are running the latest Service Release (7.13) or Service Release Candidate (7.14).

If that’s what you are using, have you tried using the Login button instead of entering the eMail address?


Hi, thank you for the response

I am using the 7.13 version, and have tried using the login button to no avail.

Hi -

Thanks. Please contact sales@mcneel.com to get you sorted with this one.