Rhino 7 overrides Windows' User defined Graphics Settings: impossible to use Rhino 7 on laptop running on battery

Hi All,

We just purchased Rhino 7, and got an update right after using it for a week.

The latest update brought a major issue that I cannot resolve. I contacted McNeel by email but I have not gotten any answer yet, so maybe someone can help me or perhaps at McNeel someone will notice these bugs and fix it.

So before the Rhino 7 update we used the Windows 10 “Graphics Settings” to fully deactivate the dedicated GPU for Rhino when using it on a laptop while travelling to save on battery power by switching to integrated GPU, this very useful solution extends battery usage time by 2 to 3-folds sometimes.

With the latest Rhino update this is not possible anymore as Rhino overrides this manual control of Windows’ Graphics Settings and forcingly switching back to the dedicated GPU usage (Nvidia Geforce in our case) provoking overheating and excessive cooling with the GPU’s fan rotating at max RPM. See these screen snipping showing that Rhino itself overrode the settings from " Power Saving Intel(R) UHD Graphics 620 to "High Performance GPU: NVIDIAMX150 ")

Before launching Rhino (after clicking on Options button and checking the Power saving mode):

After Launching Rhino, my manual setting has been overridden by Rhino to High performance mode, this happens only if Rhino is launched after the manual change to Power saving mode, it does not change until that point otherwise):

By manually turning back to “Power Saving” after launching Rhino does not do any effects, Resource monitor shows the dedicated GPU is still running at 92% full steam under Rhino instead of 0% requested by the Graphics Settings:

To change this to other power modes in the Graphics Settings, Rhino must be re-launched, but this takes back us to Step One where Windows Graphics Settings shows again that Rhino graphics is accelerated by High-Performance mode using the dedicated GPU. Rhino 7 has overridden my graphics settings without my consent.

I’d be really grateful if someone could help me to find the way to deactivate Rhino’s ability to override the Windows Graphics Settings. With this current situation I cannot use Rhino 7 on a laptop while travelling, my battery is drained in less than an hour because of the intense Graphics Card usage that Rhino forces on the system. Before the update, the battery could easily last several hours using Rhino 7 on Windows Power saving mode…and I want this feature back!

Thank you in advance for your help.

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09491, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: Commercial, build 2020-12-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 2-25-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce MX150 (NVidia) Memory: 2GB, Driver date: 12-3-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 460.79
> Integrated acclerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-3-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 2 GB

Yes, what you’ve discovered and outlined here is 100% correct.

That being said…

We are making the appropriate changes so that you can disable Rhino’s selection of the discrete GPU… But I’m wondering if you really understand and realize what that means and what all the possible pitfalls and problems you’re subjecting yourselves to by forcefully using the inferior, less stable Intel GPU? I understand that you’re saving battery life, but you’re losing a ton in performance, capabilities and efficiency.

I will try to get this change out in the next SR.


Hi @Paul_SD,

Ok, so here’s what’s going to happen (it was just easier this way, given the overwhelming number of possible configurations that can exist)…

When Rhino starts up and detects that there is no “graphics performance” setting, AND the Intel GPU is being used for Windows’ Main Display, then Rhino will force the use of the discrete (NVidia) GPU by creating a “Power/Performance” profile for itself.

This means that if you have already created a profile, then Rhino will just use it…but it also means that initially (if there is no profile), Rhino will use the better GPU. In other words… If you do not want Rhino to use the better GPU, then you must create a power/performance profile indicating that…which is what it sounds like you’ve been doing and show above. This should give you back the exact same functionality you had before.


1 Like

Hi Jeff,

Thank you for your reply. The changes you proposed will be a great update!

What I like in Rhino is that I can build large 3D models with it and it won’t really slow down my work even using an integrated GPU while on a laptop running on a battery. As soon as I can plug in my laptop I immediately switch back to High performance mode and I’m not concerned anymore about the dedicated GPU’s high energy consumption…
Cannot wait until the next update with the new options that you’ll add!

Thank you again for your help Jeff.

Hi Jeff,

I have the same issue as Paul. The reason for using the built-in Intel GPU for me is, that I don’t want the fan goin on while I record instructions videos. And in general I don’t need a lot of graphics performance for my work and prefer having long battery life and not having the fan going on.

You speak about a solution, that I don’t understand: “This means that if you have already created a profile, then Rhino will just use it”. What exactly do you mean with that? Under “graphics settings” I deleted the profiles for Rhino 6 and Rhino 7. Then I manually created a profile for Rhino 6 and set it to power saving. After starting Rhino 6 (newest SR that just came in), Rhino still overrides the settings and sets it to “high performance”.

Or do you mean some other “graphics performance” settings?



Hi @samuel.hartmann,

What you’re describing is the current behavior…What I described is how it will work in the next SR for V7.

Note: This change will not be in the next SR for V6 (if there is one)… If that’s a problem, then let me know. For now, you can just roll back to SR31.


RH-62002 is fixed in the latest Rhino 7 Service Release Candidate


Hi Brian,
Thank you for your message, I’ve just tested this update SRC and it has resolved the GPU issue.
Thank you so much.

1 Like