I had a problem with rhino after updating the graphics driver

I had a problem with rhino after updating the graphics driver. My laptop has power saving mode. When it is not plugged in, it is the graphics card that uses the cpu. When plugged in, it’s high-performance NVIDIA graphics. But when using the graphics card of the cpu when it is not plugged in, I can’t open rhino, it will be stuck when loading the plugin and then disappear. It will only be turned on when plugged into a power source and using a high-performance graphics card. I need to use rhino when not plugged in, please help me.

Set your computer to use the high performance when unplugged.

I mean I want to use rhino in power saving mode, there is no power socket where I use rhino.But Rhino cannot be opened on the energy-saving cpu graphics card, it can only be opened on the high-performance Nvidia graphics card.

That’s typically going to use the 1gb card in that mode. Use the high performance and dim your display to save power.

typical power consumption

  • LCD: 43%
  • Chipset: 21%
  • Processor: 9%
  • Graphics: 8%
  • Hard Drive: 5%
  • Network: 4%
  • Other bits: 10%

Do you know how to set Primary OpenGL as my power saving graphics card?

thank you for your reply

this didn’t help me

Via the graphics setting per the link above.

If you are intent on running in low power mode gpu keep the screen dim and work in wireframe with the least amount of objects possible.

in Rhino type SystemInfo and paste the results here please.

Rhino 7 SR27 2023-2-1 (Rhino 7, 7.27.23032.13001, Git hash:master @ 4a0030c0d354560df03764f4f49ecc5d119e5118)
License type: Educational, build 2023-02-01
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Plugged in [69% battery remaining]

Hybrid graphics configuration.
Primary display: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 2-17-2023 (M-D-Y).
> Integrated accelerated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3060 Laptop GPU (NVidia) Memory: 6GB, Driver date: 2-24-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 531.18
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-24-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\mingz\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.22353.1023

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”

Solid laptop for Rhino that will be sufficient for years to come

For testing purposes please disable the Enscape Plugin

Not working

To be clear, your Rhino isn’t working when in power saving mode.

I plugged in the power, and turned on rhino and disabled enscape, and then unplugged the power and it still wouldn’t turn on, it didn’t work.

Do you know some commands to reset rhino’s
cpu or gpu settings?

That’s all controlled by Windows & Nvidia, we just interact with the setup.

I noticed that there is a Rhino Options > View > OpenGL setting but not on my computer

I have nothing to set, my problem persists, thanks for your help.