Rhino render not using GPU even though it specifically says it is?

Hi guys,

Bit of an odd one here, and to be honest, im not even sure its even a problem as my laptop seems to be handling this better then when it was using the dedicated GPU for some reason.

I just noticed while rendering in rhino that my laptop was being suspiciously quiet (the fans are normally screaming while rendering). So i opened up task manager to check what was up. I noticed that whilst rendering, my GPU was just in use, normally this is running up around 100% when i render in rhino.

Like i say, im currently not complaining really as lately my laptop has been bluescreening a lot whilst rendering. Iv clocked the CPU up at around 101c often as well which is honestly bloody ridiculous. Iv just checked whilst this render was running and was presently surprised to see it down around 70c (and i have seen this thing spike to 90 just booting up plenty of times!). i haven’t noticed a huge difference in rendering times yet but that might just be down to me not paying attention and usually leaving my laptop alone whilst it renders.

So i guess my question is, what’s changed? iv noticed recently that my rhino updated to 8.9 and also my windows ran some chunky update as well recently. anyone know if anything major has changed? should i be concerned that its seemingly not using the dedicated graphics card even though the render window specifically states that’s what its running off? or shall i just not look the gift horse in the mouth and leave it be as its not blue screening and temps are way down?

System info below if you are interested:

Rhino 8 SR9 2024-6-11 (Rhino 8, 8.9.24163.15301, Git hash:master @ 17c7f1c7c05ff0e0b5b12288d13a911b1f0767b4)
License type: Educational, build 2024-06-11
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Plus Graphics (Intel) Memory: 1GB, Driver date: 7-21-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port 1
Primary OpenGL: NVIDIA GeForce GTX 1660 Ti with Max-Q Design (NVidia) Memory: 6GB, Driver date: 6-1-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 555.99
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-1-2024
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.9.24163.15301
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.9.24163.15301
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.9.24163.15301
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.9.24163.15301
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.9.24163.15301
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.9.24163.15301
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

When the Render Window says it is using your Nvidia GPU then it is using your NVidia GPU.

The task manager doesn’t show the correct data, instead I prefer looking at data produced by CPUID Hardware Monitor, which looks like this while rendering:

This is the utilization section, see how the GPUs are close to 100%?

Another tool I have used many times is MSI Afterburner, it will also better show GPU utilization.

One thing that might make it run quieter is that adaptive sampling is on, so if the Cycles engine sees some pixel isn’t changing meaningfully anymore before reaching the set sample count it no longer will keep rendering that pixel.