Rhino 7 [MAC] CopyToClipboard not working

Hello,

This is to bring your attention that the copy paste command from one file to another (both simultaneously open, both rhino 7 3dm files) is not working with high number of objects. when copying and pasting simple objects (box for instance), the command proceeds normally.

Screen Shot 2021-05-07 at 19.43.13
Screen Shot 2021-05-07 at 19.42.20
Screen Shot 2021-05-07 at 19.42.28

I usually I am able to copy paste 100 000 of objects (curves and surfaces…)

Any reason why is this happening ? or is it only the latest service release Bug ?

System Info :
Rhino 7 SR6 2021-5-4 (Rhino 7, 7.6.21124.09002
License type: Educational, build 2021-05-04
License details: Cloud Zoo

Apple Intel 64-bit macOS Version 10.14.6 (Build 18G8022) (Physical RAM: 32Gb)
Mac Model Identifier: MacBookPro15,1
Language: en-JP (MacOS default)

AMD Radeon Pro 560X OpenGL Engine (OpenGL ver:4.1 ATI-2.11.23)

Hello - do you mean that copy/paste of 100 000 objects used to work in the same situation but has stopped working, or it works on Windows but not on Mac, or? Do you gat any command line feedback in the target file on Paste?

-Pascal

Hello,
What I am trying to say is that in my history of using Rhino (5, 6,7) I have always been able to copy paste 100 000 objects… this is to support the idea that the latest SR of Rhino 7 is behaving in a strange manner.

Yes, I get feedback in target file where I am trying to paste (written on the screenshot) : Unable to paste, no rhino objects or text on the clipboard.

Hope this helps.
G,