Copy Paste Broke?

So I tried to copy and paste some lines, something I’ve done hundreds of times, but this time it didn’t work.

The command bar looks like this right now.
Command: '_CopyToClipboard
Command: '_Paste
Unable to paste, no Rhino objects, images or text on the clipboard.

Rhino is the only program having this issue, so I know it’s not the computer.
Does anyone have any ideas why this is happening?

I tried it in another file and it’s not working there either. I got this in the command bar:
Command: '_CopyToClipboard
Command: '_Paste
Command: Command:
Unknown command: Command:

Hi Molly, are you copying and pasting between multiple instances of Rhino? What version are you using? —-Mark

Hi Molly- please run SystemInfo in Rhino and copy/paste the results here. Sounds like it might be something solved with a re-boot or a quit/ restart of Rhino.


No, I’m copying and pasting in the same document.
I use Rhino 7

I’ve tried a reboot (I even reinstalled Rhino). The problem still persists.

Here’s the print-out to SystemInfo:

Rhino 7 SR37 2024-4-16 (Rhino 7, 7.37.24107.15001, Git hash:master @ d2e42f70b9d3aa58f6053e2998a0db2abcd7555b)
License type: Educational, build 2024-04-16
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon RX 5600 XT (AMD) Memory: 6GB, Driver date: 11-22-2023 (M-D-Y). OpenGL Ver: 4.6.0 Compatibility Profile Context
> Accelerated graphics device with 7 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1
- Secondary monitor attached to adapter port #2

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 11-22-2023
Driver Version: 31.0.23013.3005
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6103 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi @Molly_Rose_Merkert,

It looks to me that, compared to my SystemInfo, you are missing at least one plugin. That plugin is nothing to do with copy and paste, but its absence suggests your Rhino installation could be damaged. I’d suggest doing a repair on the install. In Windows 10 (11 should be similar) you would go to Window’s Settings, choose Apps & Features, select Rhino 7 from the list and choose the Modify option. That brings up the Rhino installer which will have a Repair option.

If that doesn’t fix it, please post a file with some lines that exhibit the problem so we can see if the problem persists on other computers.

I have done a repair. It is still not working.
Here’s a file with three lines and a screenshot of what happens when I attempt copy paste

3 lines.3dm (18.8 KB)


Hi Molly - are you running Rhino as administrator? Are you also logged into Windows at the same permission level?


Thank you so much to everyone who has helped, especially Pascal!
It was not running in administrator mode and fixing that fixed the problem.

Hi Molly,

Just a cautionary note: you should not need to run Rhino in admin mode. Doing so has apparently given you a workaround but there is still probably an underlying problem unless it cleared some log-jam. What happens if you try running Rhino under a non-admin account again?

Hi Jeremy- I think the key is to run Rhino at the same level of permission as logging into Windows - not necessarily Admin. As far as I know, which is not that far, this is Windows and not Rhino at work.


Hi Pascal, I inferred from Molly’s reply - and I’m happy to be proven wrong - that she is now running Rhino under an administrator account and the increased rights make the problem go away. Solving the problem for her normal user account would be a better solution because there are good security reasons for not running day to day tasks under elevated privileges.

And yes, a Windows problem rather than a Rhino one, and quite a common one at that, judging by Microsoft’s advice on the subject.