Rhino 7 crashing opening this file what's the problem?

Thank you in advance. We just upgraded to rhino 7 and at first seemed to be working perfectly and faster. A few days later I went to open a file that was last opened with rhino 6 and it caused 7 to completely lock up. I tried another file that i’d used in 7 recently and it opened no problem other than the annoying missing font error. I checked for updates and there was one so i did that and no change on that file. I tried this again on my home machine and it locked up again on this specific file (had to hard reboot). The problem seems only with certain files but we have no way to know which. Some open perfectly. I just went back and opened one from years ago no problem. I would REALLY like to know why this file won’t open and if other files we have will have the same issue.

Are others having issues opening some files and not others?

When trying to open this file (which opened fine in R6)
I’ve tried “testcloseloadingwindow” which i read about and that did nothing.
I’ve tried disabling plugins. (see systeminfo below)
I’ve tried the trick of importing the file that won’t open into a new R7 window and that seemed to work at first and opened it in wireframe top view single view panel but as soon as I tried to pan around memory usage shot through the roof and completely frozen. I gave it 10 min before another hard reboot.

I can securely upload this file to admin if provided a link. Sorry I cannot make it public. It’s 56MB

We have lots of files with pictures which seems like they will mostly be broken now (confirmed). Maybe that is my fault I can’t seem to figure out how to save a file and have the pictures stick around seems like save w/ textures even doesn’t work all the time. And old imported .dxfs from design cad. I’d really like to know what in this file is the problem.

Also, after trying to figure this out on my own a few other things I am curious about…
I read that R7 had an issue opening files that were saved in render display mode. or at least that made them slow to open. That would suck because I work almost exclusively in a modified render display mode with “no lighting” which I like because it provides real time textures but is not slowed down by lots of shodow rendering. I have shortcut keys that toggle between rendered w/ scene lighting (on) and rendered w/ lights off (off) so i can switch to the shaded view for screenshots quickly.

I also work almost exclusively in a single view panel because 4view is useless most of the time. I toggle with F1-4 the view I need. So all of my files are saved in single panel view and rendered mode which now I’m hoping isn’t going to take years off my life from just opening my own files.


Rhino 7 SR2 2021-1-12 (Rhino 7, 7.2.21012.11001, Git hash:master @ 2f08cf516ffc716c4c4a369abf7625798ef79bca)
License type: Commercial, build 2021-01-12
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 745 (NVidia) Memory: 4GB, Driver date: 5-15-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 446.14
> Accelerated graphics device with 2 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-15-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Found another file that does this. When I try importing it into R7 I immediately open task manager and just watch the non responding instance of R7 use more and more CPU and memory. After about 5 min it was at about 90% memory and I killed it not wanting to do ANOTHER hard reboot.

It would be useful if you could share a file that shows this behavior. If it is something you want to keep confidential you could share it with us using https://rhino3d.com/upload?to=nathan@mcneel.com

Your Nvidia driver is dated 5/15/20. You might want to try updating that to the latest. Even if it doesn’t fix your problem it’s still a good idea.

Are there hatches in your model? We removed a cap on extremely dense hatches in V7 that we are reinstating in a service release.

Thank you for these replies!

Nathan, I’ve uploaded a file to this link that just crashed my computer so do your worst!

AIW, I just updated the driver thanks for pointing that out.

Steve, I think the suggestion about the dense hatches is very likely the problem! The two files that I know are having the issue right now are very likely to have hatches that were imported from old design cad files (original cad drawings of projects we’ve worked on). I have noticed that sometimes the hatches import at very different scale, linotype scale also has this issue sometimes.

@stevebaer, you can find the file from our upload/download server, if you want to have a deeper look.

I tested the file with Rhino 7 SR4 2021-1-14 (Rhino 7, 7.4.21014.19001, Git hash:master @ b28138a0db397ea855a31f15a560b81fa2528bbb) - no trouble here, so maybe it is the hatch density change?

Nathan, many thanks. So I understand that to mean that this issue will be resolved in the next SR? Or is that something I can access now? It would be cool if something like that triggered a warning on import maybe “warning file contains dense hatch. click to normalize hatch scale”.

Please see the private message I sent you on this platform.

Yes, Lowell fixed the dense hatch issue. I’m not exactly sure which service release this was fixed in. It may be fixed in SR3 which we have a public release candidate for already.

Nathan, got it thanks, installed it, now it opens! success! Thanks you for the quick fix and on a Sunday no less. Great support here.
One of the files that wouldn’t open had over 1000 hatches in it some of which were quite small. Some short dash hatches that were imported into that file from old design cad had spacing of about 0.001" in the model so I’d consider that pretty dense. It also had some bad objects it seems.
Now I can get back to fumbling through my files and toiling away.

1 Like