Rhino 7 app is not running!

I just downloaded and installed the Rhino 7 for Windows Evaluation, but it won’t run. It shows the starting window, and then just disappears. Please help, very urgent :frowning: ! Here’s the debug message file:

RhinoDebugMessages.txt (21.4 KB)

Have you tried to run it in Safe Mode?
Start → Programs → Rhino 7 → Rhino 7 in safe mode

Also check that your video drivers are updated.

It does run in Safe Mode, but looks very different from normal. Very white, blank-ish. Can’t figure out how to work in that.
All windows updates are done. Shall I check any specific drivers?

Hi Prateek -

The symptoms that you describe are typical for issues with the GPU drivers. Which GPU do you have in your machine and what is the date of the drivers?

AMD Radeon™ Graphics, date 11/30/2021

Screenshot 2023-07-06 141838

Hi -
I wouldn’t count on Windows to decide if the best drivers are installed. You should check the AMD website for the latest drivers. Before doing so, however, you could try to disable “GPU Tessellation” in Rhino Options > View > OpenGL.

1 Like

Hi, I’m so glad that you’re helping. But also, I really don’t know how to do those…

  1. How do I disable my “GPU Tessellation”? Shall I run Rhino7 in SafeMode and do that?
  2. I’m unable to find “AMD Radeon™ Graphics”, there are only drivers called “AMD RaedonTM Rx 7000” etc… How do I find out what the full name/model (?) of my graphics card is?

Thank you SO much for helping !


When you run the Windows Device Manager, you should find more information on your GPU under “Display adapters”


The AMD graphics is there, and says it’s working properly. Do I need NVIDIA too, could that be the issue?
Screenshot 2023-07-06 154041

No, I don’t have an AMD device in my PC and my screenshot shows what’s in my machine.
I’d focus on disabling GPU tessellation.

I just disabled GPU Tessalation in Safe Mode. Rhino still won’t open in normal mode.

What if you, in addition to that, also move the “Level” one notch to the left? If that also doesn’t make a difference, move it another notch to the left and continue the process until either Rhino starts in normal mode or you’ve moved the slider all the way to the left.

Wim told you how to disable GPU acceleration.
To try to upgrade drivers follow this steps:

Go to AMD drivers and Support

Click on Download Windows Drivers and follow instructions to automatically install latest drivers.

After that check that Windows is updated (go in windows update and click on “Check Updates”).
A reboot is recommended after installing updates and new drivers.

I tried this, and after restarting, the Rhino app still won’t run, and also now my screen resolution is messed up. Text looks pixelated, and there’s no AMD software app anymore. There’s just an ADP Bug report application, which isn’t working either…
Would it be advisable to restore/reset/recovery work? Or would that risk deleting the files on my PC…??

Tried this, it’s all the way to the left, but Rhino still won’t open in normal mode.

In safe mode please run SystemInfo in the command line and post the results.

SystemInfo.txt (1.5 KB)
Here’s the System Info

Your driver is fairly new but the card is woefully underpowered for running a 3d Modeling software. Granted it should open and be operable in wireframe. Keep trying to get the latest driver, maybe even try older ones.

Turning of GPU tesselation will help, as well as the OpenGL level.

What is the make and model of your laptop?

1 Like

So you don’t have Adrenaline software installed? :thinking:
Well, if the driver update has made a mess, you can go back to a restore point

@Prateek_Draik At this point should be useful to know your laptop model as Jeremy suggested… could be that the manufacturer has installed some proprietary software that block driver updates…