Can not run Rhino

Hello,
My current problem is that I can not even run Rhino.

I ran it few weeks ago and it worked as well but since one week when I launched the application, nothing happens. And when I go to the Task Manager window, it tells that Rhino is open in the background. I can launch 7 Rhino it will show 7 Rhino in background tasks.

Here is my configuration:

Summary
Nom de l’appareil LAPTOP-B6U49E68
Processeur AMD Ryzen 5 4500U with Radeon Graphics 2.38 GHz
Mémoire RAM installée 8,00 Go (7,36 Go utilisable)
ID de périphérique DA7B69F9-1EC6-4A5D-B100-38759B6E3C1A
ID de produit 00325-81802-21483-AAOEM
Type du système Système d’exploitation 64 bits, processeur x64
Stylet et fonction tactile La fonctionnalité d’entrée tactile ou avec un stylet n’est pas disponible sur cet écran

Can someone help me please? Thank you

Best regards

Try starting Rhino in Safe mode to start.

Jim is right.
Start Rhino in Safe mode.
Then run SystemInfo in Rhino and post the results.

If you’re on a laptop using a second monitor, try it with just the bare laptop plugged into power.