My Rhino 7 is not running anymore. (PLEASE HELP)

Goodevening everybody,

i’m writing here because i’m experiencing a very weird thing.
My Rhino 7 actually worked until yesterday, but today when i tried (as usual) to open it, it just didn’t start.
Then i tried to:

  1. run it multiple times but nothing.
  2. restart my pc, but still nothing.
  3. uninstall and reinstall
  4. tried to repair rhino 7
  5. tried to run safe mode (not working at all as rhino)
  6. tried to update any single driver and OS

none of this stuff worked, when i double click or even try to run the safe mode, it just doesn’t open at all.

I currently use a Lab educational license given from my school that is still ongoing and working for all my classmates. I don’t think it’s an hardware issue because i’m using an Alienware m15 r3 with an i7 10th gen, GTX 2070 super (8GB), 32 GB DDR4 RAM.

I would really appreciate some help because i need to deliver a work in some days.

Thank you very much!

Giacomo Reggiani

call us at (206) 545-6877

I’m from Italy, i already tried to call but i think i need a prefix number for the specific country. Thanks for the answer!

Otherwise i just hear the voice mail.

011 for usa- or you can call our barcelona office- if you’d like help in italian-

McNeel Europe
Europe, Middle East, and Africa
Roger de Flor, 32-34, bajos
Barcelona, 08018 Spain

Phone: +34 933 199 002

If is it open i would like to call the Barcelona one so. Otherwise i could try with the US one. Could you give me the Barelona one so? Thanks

see post above-

I actually tried to call but says that the line is too busy to answer and i should recall later. Is there another way to speak with support?

How is that installed? License key installed locally, or a cloud zoo account?

I also tried to call this one but doesn’t work. Could you please write the whole number with the prefix included? Thanks.

It looks to be a cloud zoo account!


here is the link to our EU office, you can see all support options in the support link here-

i found out why were not answering, the prefix you gave me was wrong. is 001!

ahh! sorry my bad!!