Rhino 6 + vray next crash

Good evening,

I’m desperate. I purchased one month ago Rhinoceros 6 ( educutional ) and vray next.
Almost every time I launch a render it crashes, ( both vray and rhino ). I tried all the possible settings,
CPU, GPU, BOTH. Both with basic and complex renderings. What can I do?

These are the specs:
Rhino 6 SR14 2019-4-28 (Rhino 6, 6.14.19118.15561, Git hash:master @ 8f0a84997c310a7ec1a42cf2704da8daa33e3e21)
License type: Educational, build 2019-04-28
License details: Cloud Zoo. In use by: Davide D’Ambrogio ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DADOSPC

Hybrid graphics system.
Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 8-15-2018 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1050 (NVidia) Memory: 4GB, Driver date: 5-22-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.86

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-22-2019
Driver Version: 26.21.14.3086
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thank you in advance!

1 Like

Did you restart the computer?

Many times…

Did you pay for the licence?

Both of them, educational as I’m still a student.

Hi Davide.

does it crash when using interactive rendering or even non-RT rendering?

If it happens to you with the interactive, it also happens to me, during the rhino autosave.
I have already informed v-ray developers, they are working on it but have not yet figured out what it depends on.

If someone in mcneel has an idea … I am forced to disable the autosave to use the interactive render :frowning:

I rarely use the Interactive rendering… To me it happens while using the non-RT rendering, both progressive or not. I tried literally every setting possible…

Hi Davide,
Could you provide a scene that crashes ? As simple as possible. You can contact ChaosGroup support ditectly, if the privacy is a concern. Also which is your exact V-Ray version?
What does this mean:

Almost every time I launch a render it crashes, ( both vray and rhino )

You mean Rhino Render crashes as well?

Good evening. Thank you for your response

I use Rhino 6 Educational and V-Ray 4.00-01 Educational as I’m still a student.

I forward you a quite simple scen that caused me a lot of trouble because of crashing. ( i always use V-Ray renderer, with both I meant that both Vray and rhino crash at the same time).
I’m also contacting chaosgroup, as I don’t know if it’s a problem of Rhino, Vray, or even my pc.

THE NEW BANQUET @ SCHLOSS.zip

THE NEW BANQUET @ SCHLOSS.3dm

Double posts.

I’ve been told to change the topic

@dambrogio.davide
OK. Ref. the other post
Rhino 6 crashes with vray next

I don’t see a problem with this scene. I rendered 5 times, CPU/GPU progressive/bucket, still no problem.
Could you update your V-Ray installation to 4.00.02 and try again ?
If the problem persists the support team will contact you

1 Like

@dambrogio.davide 16GB RAM and 4GB GPU memory are quite limited. Best you check the memory usage per taskmanger for the RAM and GPU. Maybe you run against the limit.

On the long run I would increase the RAM first and later the GPU memory.

An other idea - maybe there is a problem with the GPU setup and the HD Graphics is more used than expected. But I don’t know so much about HD Graphics. Isn’t the RAM used by the HD Graphics too?

Could you please advise how the render job is started? Are you using Rhino’s render command?

Does the same behavior occur if you start a render from the V-Ray Toolbar or V-Ray Asset Editor?

Sorry for the late response.
Apparently that was the issue. Vray is crashing only when the render starts through Rhino’s command.
When starting directly with the Vray command it renders without problems. But I never had such problems before purchasing the new version. Is it something that will be adjusted in the next updatings?

Thank you very much for trying. Apparently the problem is the way in which the render starts. If starting with the rhino command it crashes.

Thanks! I`ve been trying to pinpoint the cause of V-Ray Next crashes since yesterday and I think this is it. As long as I start the render through the V-Ray UI, everything runs smoothly but if I start the render through the command bar V-Ray starts building some embree static accelerator or just freezes while building light cache. Thanks again.