Rhino 6 - text defaults to Arial

I have the issue.
I’m using Japanese fonts such as MS-Gothic, MS-Mincho etc…

Hi - Please run the Rhino SystemInfo command and post the result here.
-wim

Hi wim,

This is the system info.

Rhino 6 SR15 2019-6-13 (Rhino 6, 6.15.19164.21011, Git hash:master @ e41c99d36bb5000377057645e96b3ea6facf6171)
License type: 商用版、ビルド 2019-06-13
License details: Cloud Zoo.

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 7-30-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 398.82

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-30-2018
Driver Version: 24.21.13.9882
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.15.19164.21011
C:\Users\laugh\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\RealDrawings (9aaa3b93-9ea4-4425-b44e-8a8c4500c274)\1.0.7038.31206\RealDrawings.rhp “RealDrawings” 1.0.7038.31206
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thanks for that. There’s nothing out of the ordinary in that information.

On my system, when I change the font of the default annotation style in a new Rhino document and set it to MS Gothic and then create new text in a viewport, that ends up in the correct font. On your system, that reverts to the Arial font?

CC: @Alain - any ideas here?

Thanks for your reply.
For example, when I set customized annotation style -ミリメートル(建築)1/10- which displayed below image, the font automatically is overrode to Arial instead of MS Gothic which I customized for the annotation style.


RH-53375 is fixed in the latest Service Release Candidate

Oh sweet. Thanks for this!

Thank you! I’m expecting.

Hello, I have a similar problem on all four computers in my office.
If I have an annotation style that has an Arial font, it changes to Arial Black. While editing any older arial-style text, it will also change to Arial Black after double-clicking and overwriting the entire text. (When I am not rewriting the whole text, it stays right in the Arial.) It’s probably only with Arial, with the other fonts I’ve tried, it’s okay.
It started last week, I suppose after updating Rhino.
Any ideas?
Thank you.
Pavel

Rhino 6 SR17 2019-7-15 (Rhino 6, 6.17.19196.20021, Git hash:master @ 052a4af6e4e3d3afc17396aae1bbcb971546a6ce)
License type: Commercial, build 2019-07-15
License details: Cloud Zoo. In use by: Pavel (Scenografie tym)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: D5-PB

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 10-27-2017 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 388.13

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-27-2017
Driver Version: 23.21.13.8813
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.17.19196.20021
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.17.19196.20021
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.17.19196.20021
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.17.19196.20021
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Pavel,
What language is your Windows operating system set to?
What do you mean by “older arial-style text”?
Would you mind sharing your file?

Hi Alain, thank you for your response.
All our Windows are in Czech. (Two of us have Rhino6 in English, two in Czech)
By “older arial-style text” I mean any text that was created before the problem, or text created now (automaticly changed to arial black) and then manualy changed to Arial.
I am sharing the file now.
You can try “text” comand in the file and you will propably see font set to Arial black (Although styles are set to Arial)
Thanks.

Pavel,
Thanks a lot for the info. I made a fix for the problem that will go out in the next release.

Thank you.

I can confirm this behavior in “czech translated” Rhino also. When I annotated some models, the font has changed to Arial Black.

RH-53897 is fixed in the latest Service Release Candidate

I confirm that it works for me now.
Thank you.

Great, thank you. I can confirm it works on my czech win 10 as well (using EN Rhino version)

hi, I have the same problem in my Rhino 5. the version is up to date.

I can not use any other font other then Arial.

I would like to use MS Gothic

PS: I cannot run systeminfo in Rhino 5, any other suggestions to give you the needed information?

Best regards
Ralph

Hi Ralph - can you please copy and past the full Rhino version string that you can find on the About dialog box?

Also, please provide some more information on what happens when you try to use the MS Gothic font. Can you describe step-by-step what you do, including on how you start the Text command.
-wim

Hi Willem, (misschien kunne we het ook in het nederlands doen?)

See below the Rhino version:

Version 5 SR14 64-bit

(5.14.522.8390, 22-05-2017)

Commercial

SN: 4-1500-0101-100-0051000-48040

OeO Studio, OeO Studio

I work on a Mac computer with Bootcamp:

I actually also found out that I do not have the annotation styles in my document properties, see below.

e.g.:

a window pops up, I choose Gotham light, I type a text, but at enter, the font changes back to Arial.

Another example: when I open a drawing from one of my colleagues, who work on Mac Rhino, they also use Gotnham, but on my computer it changes to Arial.

Hope you can help.

Best regards

Ralph

OEO Studio

Forbindelsesvej 12, 3rd floor

DK-2100 Copenhagen Ø

Phone +45 70217080

rvdm@oeo.dk

www.oeo.dk