Rhino 6 - text defaults to Arial

Is anybody having issues with the text options? Every time i switch my text font to DIN-Pro, or leader font in my layouts, it defaults to Arial. This isnt an incredible issue but its really distracting since we are all familiar with this font.

Any ideas?

Thanks!

Are you overriding the font of an existing dimension, or changing the definition of the named annotation style you are using?

Hi John!

Its occurring whenever we use this typeface in Rhino 6. Ive set the font inside the annotation style. Even when i go into the text/leader edit window and set the font, everytime i apply and close, it does not change. This issue doesnt seem to be happening when i use any other font… Ive also tried re installing the font.

If i go back to rhino 5, i can use and set this font with no problem.

Not sure if that helps. Let me know if i can provide more information,

Thanks!

@sbontly - What exact version of Rhino 6 do you have? You can tell by running SYSTEMINFO in Rhino and looking at the first line. If you could paste that first line of output from SYSTEMINFO into a message here, it would help narrow this down.
Really, it’s probably a matter of our v6 font code not dealing with some “special feature” of that font. Some of that is in flux now in internal builds and I want to make sure we’re talking about the same things.
Thanks.

Lowell,

I figured it is something like that. Here is the info you requested. let me know your thoughts!

Thanks,
Stephen

Rhino 6 SR4 2018-4-17 (Rhino 6, 6.4.18107.1041, Git hash:master @ d4ef83ad3e6a6137f42bc2ef19083f0fcc36378b)
Licence type: Evaluation, build 2018-04-17
License details: Cloud Zoo. In use by: Stephen Bontly ()
Expires on: 2018-05-21

Windows 7 SP1 (Physical RAM: 15Gb)
Machine name: STEV_FUN-PC

GeForce GTX 750 Ti/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.35)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-23-2018
Driver Version: 23.21.13.9135
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

That font seems to do things a little differently than many others. @Alain is working on changing the Rhino font dialogs to use a different font picker. We’ll see some of that in the next few weeks. Hopefully it will make some difference for you.
We really don’t have anything to offer until then.

Thanks Lowell and Team!

Your help has been greatly appreciated. I see Rhino 6 improving Daily!

Hi Lowell,
I’m having the same issue with fonts defaulting to Arial in Rhino 6. Has this been resolved?

Thank you

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)
Licence type: Commercial, build 2018-12-14
License details: Cloud Zoo. In use by: IT Team (CAD Rhino 6)

Windows 7 SP1 (Physical RAM: 12Gb)
Machine name: T7500

Quadro 4000/PCIe/SSE2 (OpenGL ver:4.4.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.4
Shading Language: 4.40 NVIDIA via Cg compiler
Driver Date: 8-4-2014
Driver Version: 9.18.13.4066
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

The Din-PRO problem is not fixed.
What font are you having problems with?

I was trying to use Monotype Corsiva. Many other fonts seem to have the same problem.

Thankfully I still have Rhino 5 installed.

Thanks for looking into this!

-Mark

There have been changes in this area and those are on going.
I tried Monotype Corsiva. It seems to work correctly in SR6.13, but not well in SR6.12

I have the issue.
I’m using Japanese fonts such as MS-Gothic, MS-Mincho etc…

Hi - Please run the Rhino SystemInfo command and post the result here.
-wim

Hi wim,

This is the system info.

Rhino 6 SR15 2019-6-13 (Rhino 6, 6.15.19164.21011, Git hash:master @ e41c99d36bb5000377057645e96b3ea6facf6171)
License type: 商用版、ビルド 2019-06-13
License details: Cloud Zoo.

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 7-30-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 398.82

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-30-2018
Driver Version: 24.21.13.9882
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.15.19164.21011
C:\Users\laugh\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\RealDrawings (9aaa3b93-9ea4-4425-b44e-8a8c4500c274)\1.0.7038.31206\RealDrawings.rhp “RealDrawings” 1.0.7038.31206
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thanks for that. There’s nothing out of the ordinary in that information.

On my system, when I change the font of the default annotation style in a new Rhino document and set it to MS Gothic and then create new text in a viewport, that ends up in the correct font. On your system, that reverts to the Arial font?

CC: @Alain - any ideas here?

Thanks for your reply.
For example, when I set customized annotation style -ミリメートル(建築)1/10- which displayed below image, the font automatically is overrode to Arial instead of MS Gothic which I customized for the annotation style.


RH-53375 is fixed in the latest Service Release Candidate

Oh sweet. Thanks for this!

Thank you! I’m expecting.