Rhino 6 SR8 Broken

Since I installed R6 SR8, I can not open some rhino files.

When I try to open a file, a popup shows “Unspecified error”.
The Rhino Viewport is a solid black rectangle.
I can type and click things, but nothing is recognized.

I updated my display drivers and restarted my computer, but I still have the same issue.

Here is my system information:

Rhino 6 SR8 2018-8-28 (Rhino 6, 6.8.18240.20051, Git hash:master @ )
Licence type: Commercial, build 2018-08-28
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name:

GeForce GTX 1070/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.25)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-16-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.8.18240.20051
C:\Users\ \Documents\Repos\rhino6-developer-samples\rhinocommon\cs\bin\SampleCsEto.rhp “SampleCsEto”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\CGridderInterface (43163e19-cd5b-40f9-a314-5855d2caa1fd)\2018.7.24.661\BlockWorks-prealpha\Rhino 6\CGridder.rhp “CGridderInterface”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Users\ \Documents\Repos\rhino6-developer-samples\rhinocommon\cs\bin\SampleCsSettings1.rhp “SampleCsSettings1”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.8.18240.20051
C:\Users\ \Documents\Repos\rhino6-developer-samples\rhinocommon\cs\bin\SampleCsMain.rhp “SampleCsMain”
C:\Users\ \Documents\Repos\rhino6-developer-samples\rhinocommon\cs\bin\SampleCsSettings2.rhp “SampleCsSettings2”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Jake - does Rhino work in Safe Mode?
Windows start menu > type ‘Rhino 6 in Safe Mode’
Can you post a file that does not work? And, are you using any plug-ins that are not default Rhino ones?


I am rolling back my update to R6 SR7 right now to see if that will fix the problem.
I will report back either way. If it doesn’t fix the issue, I will try SR8 in safe mode.

I can’t share the model because it is from a client.
I will also try with some other models.

Thanks for the help,

Rhino6 SR7 is having the same error.

I am going to install SR8 and try some other files to see if I can isolate the issue.

Hi Jake - if you can send a model to tech@mcneel.com or zip and upload to www.rhino3d.com/upload, to my attention, those are confidential and not public.



Thank you Pascal,

I will send you a copy of the file.

I just tested in Safe Mode and I am getting the same error.

Hi Jake do any files open normally?
Also, were you running a previous SR of Rhino OK before or is this a new installation?


Most files are opening normally.

This file wont open on my computer but will open on my colleagues’.

I can see at least two computer having the issue on different files.

I sent the file to tech@mcneel.com.
I also tried opening a Rhino4, Rhino5 and Rhino6 version of the file and they all failed.

Do you know if these files have layout and detail views in them?


I’m assuming these files used to open under SR7 but now don’t?

  1. You were working just fine on these files in SR7…
  2. You updated to SR8…
  3. Now the same files you were working on no longer load…
  4. You rolled back to SR7…
  5. The same files you were working on in #1 now don’t load.

Does that sound right?


No, it doesn’t seem to have anything special.

I just tried copying the geometry into a new file then saving as to eliminate the possibility.
The copied file still failed to load.

I tried opening rhino by clicking the file and it made a McNeel Error Report.
I sent it with the 3DM file.


I thought this file opened in SR7, but I am seeing now that it is a newer file.

It does open on other computers using SR7 or SR8, but not mine in either.

Actually, I just found a file that did open before I installed SR8 and does not work now.

Do you want me to go back to SR7 to see if this file works?

Ya, it opens here just fine in SR8, SR9 RC and SR10 WIP … So something seems messed up with your configuration… Have you applied any other updates to your system recently?

I thought you had already rolled back to SR7 and found the same problem…then went back to SR8 and tried safe mode, and had the same issue there as well… No?


I did that process but I was using a new Rhino file that I had not tried to opening before updating.

I just found a file that I was using earlier this week that I can’t open now.

I have an update available for windows that I am going to try to install now.
I tried updating my graphics card after I found the issue today.

Ok, then I would roll back to SR7 again, and see if that file now opens successfully…

standing by

I wouldn’t update anything yet… Hold on…

I am uninstalling rhino and reinstalling SR7.
I’ll let you know how it goes.

Give me a minute. I am going to restart my computer as well.