R8 - not opening any more

hey,

r8 is not opening any more after crashing the whole system.

getting this error message:
r8-error

puh,
Benjamin

What do you mean by “crashing the whole system?”

That appears to be the ‘server is busy…’ message that pops up usually when you are trying to open up a new Rhino session while another is really busy working on something.

Jim,

crashing the whole system means that the machine was frozen and I had to hard reboot it again.

anyway, I cant open rhino anmore.

But that message is telling you there is a Rhino open, doing something.

Can you open Rhino in Safe Mode and run SystemInfo in the command line?

To run via safe mode search for Rhino 8 in Safe Mode in the Windows run

Japhy,

Rhino 8 SR6 2024-4-2 (Rhino 8, 8.6.24093.11001, Git hash:master @ de3127ef7b7fd6e4c2fef07a9a1bc10c8e1942a3)
License type: Kommerziell, build 2024-04-02
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 SUPER (NVidia) Memory: 8GB, Driver date: 4-2-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.12
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-2-2024
Driver Version: 31.0.15.5212
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

after checking for updates getting the error message above again.

Thanks, SystemInfo looks ok. This is not from safe mode, so you are able to open normally sometimes? Is there a particular file involved?

Not seeing any crash reports, are you given an opportunity to save one?

this was from save mode, at least I used the command “rhino 8 save mode”.
I got an interesting error saying: This file type is not supported by rhino 8

ok, this was my mistake. but if i am following your instructions this is all i get. the search resulkts for safe are just showing rhino 7 safe mode.

The shortcut is in the same folder as Rhino 8

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Rhino 8

When running in safe mode the video drivers are disabled, the report will look like this…

From Start, App an Rhino Safe Mode

1 Like

this is all I get. I will try from folder direct.

Rhino 8 SR6 2024-4-2 (Rhino 8, 8.6.24093.11001, Git hash:master @ de3127ef7b7fd6e4c2fef07a9a1bc10c8e1942a3)
License type: Kommerziell, build 2024-04-02
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 SUPER (NVidia) Memory: 8GB, Driver date: 4-2-2024 (M-D-Y). OpenGL Ver: (null)
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL (null) (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 4-2-2024
Driver Version: 31.0.15.5212
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24093.11001

I’m not sure what is going on here.

What steps do you take to repeat the crash?

  1. rhino freezes the system
  2. hard reboot
  3. restarting the system and trying to open rhino. there no other instances of rhino started

I would try to make an installation repair (from app, find Rhino 8 → click Modify → click Repair)


Sorry for Italian descriptions but I have italian OS.

thank you Lucio, this is not working, I tried that before. I will try to setup a new installation of rhino. that should work.

1 Like

Is this happening after upgrading to 8.6?
Have you tried to install Service Release Candidate?

Lucio,

yes, I have 8.6 installed due to the changes of the “use model scale” for line types.
unfortunatly I cant open rhino any more. when I open it with the safe command from win search it opens, but I am not able to da anything else > error.