Rhino 6: Solids in Blocks do not shade Fills

Hi,

as the title reads, as soon as a solid is within a block, using a clipping plane on it will not display fills.

please fix :slight_smile:

thnx
Daniel

1 Like

Hi Daniel - at least in a simple test this works here…

image

Does the simple case (make a box, Block it) work for you?

-Pascal

fascinating.

but not working on my install:

for the record:

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 7 SP1 (Physical RAM: 48Gb)

GeForce GTX TITAN X/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.77)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 12 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Pascal,

thanks for looking into this.

I am wondering if any other useres have this problem:

because I just tried on my laptop (surface book / nvidia 965m) and I have the same problem.

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

GeForce GTX 965M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.08)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-19-2017
Driver Version: 23.21.13.8808
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi,

@pascal, I can confirm the same.


SolidInBlock.3dm (496.8 KB)

Thanks,
Dmitriy

OK- thanks… @Dmitriy, I see it as well in your file but not in one I make from scratch… still poking at it. Some other ugly things as well in here.

https://mcneel.myjetbrains.com/youtrack/issue/RH-45930

-Pascal

yeah, I have seen the ?? in one of the two files I made. my first impression was somehow the ground plane is showing… in this image it is not a rectangle but like a plane on the cplane intersecting the sphere.

Hi,

Not sure what the status is but I’ve encountered issues with this as well please see below a list of images and different behavior as well as a file containing the geometry.

steps to replicate issues (units mm):

  1. create a box in origin 100,100,100.
    2.copy to the side and create a block with the origin of the block being the left bottom corner
  2. create a new box in 1000000,1000000,1000000 with same dimensions as above 100,100,100
  3. copy next to it and create block with its origin bottom left corner
  4. create a clipping plane for the objects far away and one for the objects next to origin

In my file I have named the objects next to the origin “origin” and the ones far away “far” for easier navigation.

Looking forward to thoughts regarding this issue.
Best,
Tudor

190321_BlocksClippingPlane.3dm (73.0 KB)

Anyone else experiencing any of the above?

I experience a load of display issues, this is one of them.

Another is if I Enable Clipping Plane whilst in my customised display mode Rhino reverts to the default Shaded display mode. I tend to only experience these issues in data-heavy files, mind you.

There’s a few more issues to list, but I won’t do that right now because it’s a lot of information to grasp.

I’m using a Surface Book 2 15" with GTX 1060, 16gb ram.