Rhino 6 - Rendered view keeps displaying bump map

unhandled

(Bartlomiej Stachurski) #1

Hi all!

I recently upgraded to Rhino 6 and I encountered a weird problem with the Rendered view, in which I am working most often. Like I wrote in the title, in this view Rhino keeps displaying the bump map on the materials. In earlier versions of Rhino this could be easily turned off by unticking the ‘Use advanced GPU lighting’ option, but now it doesn’t seem to do anything, the bump is still on. It slows down the display, looks ugly and I don’t need it, does anyone have an idea what could be the reason for this?

I am using Vray 3.6, but the problem keeps persisting no matter if I use Vray materials or Rhino ones, it displays the bump map either way. I still have Rhino 5 installed and that one doesn’t have this problem.

I haven’t upgraded my windows or graphics card for a long time, so I fixed that too, but it didn’t change anything. I am working on Windows 7 professional, using a NVIDIA GeForce GTX 1060 if that helps anything…


(Pascal Golay) #2

Hello - does the bump-mapping look correct? It seems like since you’re asking for a rendered mode, as long as it displays correctly, you’re getting what you should here…

-Pascal


#3

You could create a custom display mode showing just the diffuse map


(Bartlomiej Stachurski) #4

Hey! Yeah, I am getting the correct bump map, but the problem is, I don’t want to see it here.

Here is the comparison (my bad, should have posted this at the beginning too):

This is how it should look with the ‘advanced GPU lighting’ disabled - or at least, how it looked in Rhino 5 with that option disabled. Just a flat texture - which is much easier for me to use. I don’t want to see the bump mapping in the Rendered view, but I am unable to turn it off in the new version…

I can achieve this look by turning off the bump map in the material itself, but I don’t want to juggle all the bump maps before every rendering.

Thanks for the reply!
Bartek


(Bartlomiej Stachurski) #5

Thanks for the reply!

What do you mean by that? I didn’t find such an option there, just displaying the rendering material or the object color. I managed to get rid of the bump map display by changing the lighting method to ‘No lighting’, but that makes single-material objects much more difficult to recognize.

Also, bump map or not, it seems weird that the ‘advanced GPU lighting’ option doesn’t seem to do anything since the upgrade…


#6

I’ve this custom display mode and helps me a lot!

Shaded_Mat.ini (12.4 KB)


(Bartlomiej Stachurski) #7

Thanks, this gets rid of the that bump and the line edges help discern shapes even without the shading :slight_smile:

Still, the problem with ‘Advanced GPU lighting’ persists. Would be good to know if that’s only mine problem, or is that more widespread…


(Pascal Golay) #8

Hi Bartek - I guess it is a fix that does not work for you more than a bug - bump mapping just works now in general - I don’t know that it was ever specifically designed to control bump mapping in V5, it just happened to work that way… that’s how it looks to me from here, I’m happy to be wrong though… . @jeff - am I making stuff up?

-Pascal


(Bartlomiej Stachurski) #9

Hey Pascal, thanks for the reply,

It seems to control the mapping, it even says so in the help file, under ‘Display Modes Options’:

“Note: In order to display bump mapping, in Rendered mode, the Use Advanced GPU lighting setting must be checked.”

I get the bump mapping regardless of whether the setting is checked or not…