Bump materials purple in rendered display mode

unhandled

#1

Hi, I often use the rendered display mode to do quick screen grabs for clients before rendering full scenes using Octane. Is there a way for materials that have a bump applied to them not to show up as purple without removing the bump from the material. This happens with both rhino and octane materials so I’m pretty sure it’s a rhino setting. I’ve gone through all the Rendered Display Mode settings but can’t seem to find a setting for this? Can it be changed?


(Brian James) #2

That looks like a normal map is being used in the color channel of the assigned material. Can you post a 3dm with the textures embedded? Just use Rhino Render to set it up for now.


#3

Hi BrianJ, I’ve attached a file here. What I get is if no bump is added, the material is the correct colour (e.g. bamboo) if I add a bump the rendered display mode shows the material in purple. It renders fine but I’m wondering if there’s a way to stop the material showing in purple in the rendered display mode without having to modify the material (delete the bump). Bump example.3dm (2.7 MB)


(Brian James) #4

Thanks for the file. The texture maps weren’t embedded so I used a different HDR… I had the Bamboo one for the color channel and the bump is a procedural stucco. It looks fine here in default Rendered mode…


It might be an issue with your graphics card or the driver installed for it. Post a screenshot of Options>View>OpenGL please when you can.


#5

Hi BrianJ, I’ve solved it. Thanks for helping me narrow it down. When I restore default settings it works, but my customised settings don’t. It seems that I had ‘Use Advance GPU lighting’ turned on that makes all but the ‘Scene Lighting’ Lighting method show the bump as purple. With that off, all lighting methods show the material without the purple bump.


#6

anyone know why this happens? and if rhino 6 has solved this?


(Nathan 'jesterKing' Letwory) #7

There shouldn’t be problems showing bump maps. You can verify with Rhino 6 Eval.


#8

may be a question for the chaos group team- but certainly if i have a vray material that has a bump map on and I have advanced GPU lighting enabled I get almost a “stochastic flake” effect on the material in the viewport.