Rhino 6 Performance Issues

Hi All,

I’ve been troubleshooting this for a few days but can’t figure out a solution.

My issues are:

  1. I don’t think i’m tapping into the full potential of the hardware (surface book2,16gb ram, GTX 1060 etc.)

  2. Regardless of issue 1, I’ve been working with a simple model that grinds. Zoom, orbit, cursor movement lags. I’m not sure if its the model or a setings…this old wiki entry helped a bit: https://wiki.mcneel.com/rhino/slowcursor

Here’s a couple of tests I did:
rhino test.zip (17.3 MB)

Test 1 File:

Cursor lags when drawing. Zoom, pan, orbit is slow. This happens whether in rendered mode or wireframe or shaded.
Video drivers are updated. GPU tessellation on / off doesn't help

testMaxSpeed: Time to regen viewport 100 times = 16.34 seconds. (6.12 FPS)

After turning off nvidia Vertical Sync
testMaxSpeed: Time to regen viewport 100 times = 7.63 seconds. (13.11 FPS)

Rhino5:
testMaxSpeed:Time to regen viewport 100 times = 1.64 seconds

Test 2 File:

testMaxSpeed: Time to regen viewport 100 times = 6.17 seconds. (16.20 FPS)

After turning off nvidia Vertical Sync
testMaxSpeed: Time to regen viewport 100 times = 6.11 seconds. (16.37 FPS)

Rhino5:
testMaxSpeed: Time to regen viewport 100 times = 0.38 seconds

Rhino 6 SR1 2018-2-6 (Rhino 6, 6.1.18037.13441, Git hash:master @ 5a33e6871b94d32ba552468218cef0ad8d3d1263)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

GeForce GTX 1060/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.71)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

1 Like

Hi Danny - just as a test, try turning off ‘GPU Tessellation’ in Options > View > OpenGL page. Does that do anything?Also make sure drivers are the latest, from the nVidia website, don’t trust Windows to tell you if it’s up to date.

-Pascal

Yeah I’ve tried that. It doesn’t help. Saw your suggestion on another post.

Hi @pascal,

Here’s what I’m experiencing…everything seems to work ok until I start drawing.

Hi @Danny_Le,

I would recommend you fully uninstall your NVIDIA driver and download and install the latest from here: http://www.nvidia.com/download/driverResults.aspx/131443/en-us.

-David

Hi @DavidEranen,

Wish I could. Unfortunately, I’m running Rhino on Microsoft’s Surface Book 2 15 which uses a GTX 1060:

https://forums.geforce.com/default/topic/1038669/geforce-drivers/surface-book-2-15-inch-cant-install-drivers-after-390-65/

The Surface Book family comes with OEM drivers / firmware:

https://www.microsoft.com/en-us/download/details.aspx?id=56261

I was able to install Nvidia driver 388.71 (anything after was incompatible with the hardware) yet the display & drawing issue persisted. I’ve ‘Fresh Started’ my computer, reinstalled / repaired Rhino 6, turn GPU Tessellation off…all to no avail.

Is anyone at Mcneel using an SB2? Can they replicate the issue?

I see,

@stevebaer don’t you have a Surface Book 2? Have you heard of anything like this?

-David

thanks @DavidEranen. @stevebaer to be clear, the Fresh Start got my testmaxspeed to be around 55-65 fps…however cursor is still stuck in mud when I initiate any drawings ie polyline, copy, move etc.

@jeff is this similar to the feedback issue that you were seeing on a Dell computer?

Nope, doesn’t look/sound like it… His views are working just fine, but apparently they’re just slow. With the Dell issue, the views appear to be frozen, even though drawing is occurring.

Sounds like something is bottlenecking in the feedback mechanism…

-J

@Danny_Le try turning Antialiasing to None in Rhino’s OpenGL settings page and restart Rhino.
Does this make a difference? We use slightly different approaches to drawing when AA is enabled.

I’ve got the same thing. When moving the simplest item, it acts like it’s attached to a rubber band. Very very frustrating. I gotta say, I’ve never had to come on here to look for as many fixes as I have in the past week after upgrading to 6. I’ve been pretty frustrated with a number of things, I sincerely wish mcneel luck with making this version stable

1 Like

Similar issue here. reinstalled all the drivers for my gtx 980 but that didn’t help… becomes very apparent on bigger models, rotating zooming is smooth, but interacting cuts fps in half or more. Also when isolating a part of the model to work on it fps drop severely compared to viewing the whole model

I have experience de same issue…finally, after changing a lot of parameters even for the NVIDIA card and in Rhino i found the solution here

https://wiki.mcneel.com/rhino/slowcursor

Turning off the vertical sync of the nvidia driver…it works for me¡

Same issue here. If I move the cursor, the dot in the middle is lagging extremely. Though it moves so smooth, I feel like it’s a function which you could disable. Unfortunately I tried everything I found in the web, also turning off the vertical sync of the nvidia driver, but nothing helped.

Same issue here… none of the above solutions have worked thus far.

I have an SB2 16GB/ NVIDIA GTX 1060 (6GB), performance is really good in Rhino. A bit slow only on massive files but nothing like lockdowns, non-responsiveness or drawing issues.

Maybe the units that you guys have are defective? (MIcrosoft makes nice laptops but there have shipped a lot of lemons in the past, especially SB1). Do you see the Nvidia cars being detected and used by Rhino?

I wonder if there’s a test that McNeel can provide so we can compare two equally sourced laptops and see what we find? Would running Holomark tell us anything?

G

Same issue here… i have just set up a fresh windows 10 with a new GTX 1060 (6GB) an have a lot of lagging when rotating the views with my SpaceMouse.
Until yesterday i used Windows 7 with an old 2GB Nvidia GPU and everything was fine back then…

I having the same issue. I can rotate around the model fine but as soon as any command is carried out (even something a simple as move) there’s a 3-5 second lag.
Wasn’t having this issue a month ago with the same size model.
Updated graphics drivers, tried the various OpenGL options, nothing.

Anyone had any luck?

Many thanks

Hi,

I have the same issue with apparant slower response in Rhino 6 compared to Rhino 5.

I have a HP ZE220 Workstation with a Quadro P400, a recent update from Quadro 600.

Both Quadro 600 and P400 works fine with Rhino 5 and a Holomark2 test gives a high score.

The driver for P400 is up to date. I have made an effort in removing the old driver before the installation of the one for P400.

I notice that Rhino 5 File->Settings->View->OpenGL reports correct driver and Opengl Version 4.6 (v 397). Rhino 6 insists on using only 3.3 (With NVidia driver 397).

I also have trouble with the raytracing mode. I can see the lines of the model (when enabled) and the model can easily be repositioned and rotated but no light tracer appears.