Rhino 6 Performance Issue


(Jdrass) #1

I am having an issue with a number of machines and Rhino 6. The users are complaining that the scaling of shapes is slow and very laggy. When compared with Rhino 5, there is absolutely no lag. I have changed a number of video settings and updated the video drivers with no improvement. The hardware seems to exceed the program requirements. Does anyone have experience resolving these issues?

Precision T7600 Dual Xeon E5-2690 3.9GHz | 32GB Ram | Quadro K4200 | SSD
Precision M6800 i7-4810MQ 2.8GHz | 16GB | Quadro K4100 | SSD


(Pascal Golay) #2

Hello - can you describe in a little more detail what causes the problem? Is it scaling as in using the Scale commands? Can you provide a file that shows the problem (www.rhino3d.com/upload)?

-Pascal


(Jdrass) #3

I asked the users to provide a video of the issue and am waiting for that. When they show it to me, it looks like they are increasing / decreasing the size of an object. The cursor will stop moving and they will have to wait for the object scaling to catch up to the movement. In Rhino 5, there is no delay and the object scales in perfect timing with the cursor movement. We have the same results on existing models as well as newly created files.


(Brian Gillespie) #4

What version of Rhino are your users running? 6.10? 6.9?


(Jdrass) #5

Version 6 SR9
(6.9.18271.20591, 9/28/2018)

I’ll install 6.10 to see if that helps.


(Jdrass) #6

6.10 helped a little bit. The system that is most effected has a 27" Cintiq attached to it. We noticed that the lag was much greater on this screen compared to a normal 27" Dell monitor on one of the other computers. Again, in Rhino 5, there is no lag on any of the screens.


(Jdrass) #7

Following up on this. Any ideas?


(Brian Gillespie) #8

We made a fix in SR12 that might fix this; there will be an SR12 release candidate available next Tuesday.


(Jdrass) #9

I was able to Install SR11 today and didn’t notice any change. When is 12 available?


(Wim Dekeyser) #10

Hi - We ended up releasing a new Release Candidate for SR11 instead. The first Release Candidate for SR 12 should be available next Tuesday.


(Jdrass) #11

As a follow-up this, SR12 did not resolve the issue.


(Pascal Golay) #12

Hello - it looks like we have not yet asked for the output from Rhino’s SystemInfo command - can you get that for a couple of the machines that show the problem? I kind of suspect a plug-in may be involved.

-Pascal


(Jdrass) #13

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)
Licence type: Commercial, build 2018-12-14
License details: Cloud Zoo. In use by: X ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: X

Quadro K4200/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 411.81)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-16-2018
Driver Version: 24.21.14.1181
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Pascal Golay) #14

Hello - thanks - could you please try disabling VRay in Options > Plug-ins page and then close and restart Rhino - does the problem persist?

-Pascal