Surface book 2 + Rhino 6 lags

Rhino 6 cursor lags with SB2. Anyone found solution to this? I couldn’t find straigth forward solution to this.

Hi - Please run the Rhino SystemInfo command and post the result here.
Thanks!

1 Like

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Educational, build 2019-02-27
License details: Cloud Zoo. In use by: tony.yau ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-Q1EJ6IU

Hybrid graphics system.
Primary display: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 9-26-2018 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 3-1-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 419.35

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-1-2019
Driver Version: 25.21.14.1935
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

It is identical problem that @danny_le addresses here in another thread.

Hi Tony,

FWIW your tests run acceptably (for me) on my first gen Surface Book, so hopefully there is a solution out there.

Regards
Jeremy

1 Like

Hi - did you try the other things that are mentioned in that thread?
(i.e. turning off Antialiasing, turning off the vertical sync, making sure that the UseCoreProfile setting is set to false)

Is the cursor also lagging when you start Rhino in safe mode?

Hi,
Turning off the vertical sync from Nvidia control panel did the trick. Also, there was no lag when opened in safe-mode before.

Thank You @wim and @jeremy5.

1 Like