Rhino 6 not responding when saving, opening or during copy & paste (for files with plugin data)

Hi All,

I have this problem of rhino 6 not responding whenever I tried to save, open or control-c something. It only happened yesterday (out of no where) without any rhino update or me installing anything new on the computer.

I have tried to troubleshoot this problem and narrowed this down to something relating with rhino plugin data. This “not responding” issue is solved when I save as without plugin data. My file goes back to normal after doing that.

But this does not solve the root of the issue. Apart from having to save as every working rhino file, I also have files with file size of 1.5GB or larger that cannot be opened at all. As I cannot open the file, the save as without plugin data trick does not work on it.

Anyone have any idea what the issue might be? Let me know if any other information will help diagnose this. Thanks!

Please see below for system information:
Rhino 6 SR34 2021-2-3 (Rhino 6, 6.34.21034.07001, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-434I23C8

Computer platform: LAPTOP - Plugged in [89% battery remaining]

Hybrid graphics configuration.

  • Primary display: Intel® Iris® Xe Graphics (Intel) Memory: 1GB, Driver date: 10-28-2020 (M-D-Y).*
  • Integrated graphics device with 4 adapter port(s)*

  •    - Windows Main Display is laptop's integrated screen or built-in port*
    
  •    - Secondary monitor attached to adapter port #2*
    
  • Primary OpenGL: NVIDIA GeForce MX450 (NVidia) Memory: 2GB, Driver date: 7-5-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 451.67*
  • Integrated acclerated graphics device (shares primary device ports)*

  •    - Video pass-through to primary display device*
    

OpenGL Settings

  • Safe mode: Off*
  • Use accelerated hardware modes: On*
  • Redraw scene when viewports are exposed: On*
  • Anti-alias mode: 4x*
  • Mip Map Filtering: Linear*
  • Anisotropic Filtering Mode: High*
  • Vendor Name: NVIDIA Corporation*
  • Render version: 4.6*
  • Shading Language: 4.60 NVIDIA*
  • Driver Date: 7-5-2020*
  • Driver Version: 27.21.14.5167*
  • Maximum Texture size: 32768 x 32768*
  • Z-Buffer depth: 24 bits*
  • Maximum Viewport size: 32768 x 32768*
  • Total Video Memory: 2 GB*

Rhino plugins

  • C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.34.21034.7001*
  • C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit” *
  • C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC” *
  • C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render” *
  • C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.34.21034.7001*
  • C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” *
  • C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots” *
  • C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.34.21034.7001*
  • C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.34.21034.7001*
  • C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse” *
  • C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”*

Also tried this suggestion but did not work. V6 - "Writing failed for unknown reason" - #13 by andy

Hello - does this happen in a new file, with say just a box added? Please start Rhino from scratch and create a new file (New command) with no template file, then test.

-Pascal

Hi Pascal,

Thanks so much for replying! In a new file I can save, copy and open, no issue. For existing files that I can open and read, I can solve it by “save as without plugin data” and the file will be back to normal (even when saving with plugin data after). I have some issue where I could not open/read a couple of files that are 1.5GB large, hence seeking help to solve the root of the issue. Do you think all my existing files got corrupted by some plugin? Cause it doesn’t make sense to me that new files are ok when plugin data is saved by existing files have issue.

When I save existing files with plugin data, the file will not respond and a .tmp file will be created. Not sure if it will help but I’ve attached the file in the link below:

-Yu Jie