Rhino 6 Keeps is not responsive

Hi everyone, so recently I’ve been working on a school project for studio when only as of the past couple days I’ve been running into issues where Rhino will stop responding randomly, and I become unable to save my work. I also am unable to close out of windows or the Rhino file itself, but I did a fresh install of windows and don’t think it could realistically be that. I’ve checked my drivers for updates and everything is up to date that I can see, and I’m really just not sure where to go from here. Any help would be greatly appreciated

Rhino 6 SR34 2021-2-3 (Rhino 6, 6.34.21034.07001, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)
License type: Educational, build 2021-02-03
License details: Cloud Zoo. In use by: Zack K ()

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: ZACKS-PC

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 960 (NVidia) Memory: 4GB, Driver date: 3-11-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.92
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-11-2021
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
D:\Program Files\Rhino\Plug-ins\Commands.rhp “Commands” 6.34.21034.7001
D:\Program Files\Rhino\Plug-ins\rdk.rhp “Renderer Development Kit”
D:\Program Files\Rhino\Plug-ins\RhinoRender.rhp “Rhino Render”
D:\Program Files\Rhino\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.34.21034.7001
D:\Program Files\Rhino\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
D:\Program Files\Rhino\Plug-ins\NamedSnapshots.rhp “Snapshots”
D:\Program Files\Rhino\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.34.21034.7001
D:\Program Files\Rhino\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.34.21034.7001
D:\Program Files\Rhino\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Users\zkgol\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”
D:\Program Files\Rhino\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”

Here is the systeminfo as well!

Hi Zak,
have you tried to disable 3rd part plugins (like vray)?
Are you working on files stored locally or on the cloud?

Hi, I haven’t tried disabling Vray yet, but mainly because I need it to render my project out. I was previously working from the cloud and thought that may be the issue, but since have downloaded the project locally and have been trying to work from there with a little more success.

Hello - I would save to the local disk - say the desktop - to see if that makes any difference, and as Lucio suggests, when you have made your renderings, test after disabling Vray and twinMotion in Options > Plug-ins page (Note: close and re-open Rhino after disabling) , and see if that helps.