Save, not responding

Hi, I’ve been working with a file that’s pretty big (270MB), and every time I save, Rhino 6 greys out and has the (Not Responding) parenthetical. It eventually does save, but at least a minute or two later. I tried purging the file, disabling the VRay plug in, “saving small” and saving without Plugin data and none of those have done anything!

I don’t think the file has any really large meshes or anything either. I tried deleting the layers that I thought might be problematic–they weren’t the issue. I’m not having the issue with other files in rhino.

Any help would be great!

How full is your SSD/Hard drive? If it’s a HD, has it been defragmented lately?

If seen hangs while using Cycles in real-time raytracing mode.

From what I have seen, saving small usually makes a big difference, stating as someone who always saves small.

SSD is 83% full (which is where rhino lives), but the HDD is only 30% full (which is where the file is being saved).

I’m not using cycles, so I haven’t noticed any issues with that, and the small save still made rhino non-responsive.

Not sure if this will help but you can try copying the model to a plain new 3dm file, and see if the saving time is shorter in the new file. If yes then that means its the plugins making it slow. If not then that means your model might be too big with too many detailed parts which you might need to use blocks or just simplify some of the geometries. Try not to include any mesh when copying to the new file, they are usually the problem maker. xp


Hello - are you saying it does not start saving for a couple of minutes, or it’s done saving in a couple of minutes?

Please run the SystemInfo command in Rhino and post (copy/paste) the results here.


@Kid: Looks like it’s some meshes that I have. I pasted into a new document with and without them and the file goes from 180 MB and not responding to 100 MB and it responding.

@pascal: I think more that it doesn’t start saving for a couple of minutes. I get the little blue loading wheel for a bit and then it saves. System info below:

Rhino 6 SR20 2019-11-18 (Rhino 6, 6.20.19322.20361, Git hash:master @ f60ce76e397bba419469ae5277fc1578641caa3a)
License type: Educational, build 2019-11-18
License details: Cloud Zoo. In use by: k ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-23O467M

Hybrid graphics system.
Primary display: Intel® HD Graphics 620 (Intel) Memory: 1GB, Driver date: 11-11-2016 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 950M (NVidia) Memory: 2GB, Driver date: 11-20-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.41

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-20-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

@k11 Are your meshes from sketch up warehouse? Try to not use meshes from unknown provider because it might not be modeled in a decent way which causes all these problems. If you really need to use that specific mesh reference then you might need to clean it up in a new file first (Check for any bad meshes, and try fixing the meshes with the mesh tool palette), If its a simple object then you might as well convert it to poly surface and clean it up (remodel or rebuild some surfaces). Link it back to the host file after all this and Rhino should work smoothly (Embed usually increases the file size so if the mesh is just for reference then link would be a better choice).

Gotcha! They’re from a furniture manufacturer, but I’ll try cleaning them up! Thanks!

Hi - if it’s possible to send just the meshes that are causing long saves, please do. That might help us checking what’s going on with these.