Toolbars won't stay put

Since last week’s SR candidate update, my toolbars re always moved when I re-open rhino. Any tricks to fixing this on my end?

Go the the “Standard” tab at the top, right click on a blank area of that tab, you will get a pop up menu that has a few items on it like “show tool bar”, and “new button”. At the bottom of that menu is an option to “Lock Docked Windows”. Click that. See if that solves it.

I was hoping that would be the easy fix, but the toolbars still come back to their original positions.

Have you made the Rhino window smaller then your entire screen, then dragged the tool bars out to your desk top? Toggle the lock dock tool bar menu, to see if that might help?

I should note that I also uninstalled the Bongo eval around the same time.

That doesn’t help either.

Hello - can you try running Rhino as an Administrator? (RMB on the Rhino icon - even if you are logged in as an admin- and choose Run as Administrator) Rearrange, close, reopen normally - any better?


Nope, still not staying put.

Sorry I cannot be of more help. Best I can do is to suggest ways of messing with it (noddling). Have you set up a rhino drawing just as you like it and saved it as a drawing? even if it does not have anything drawn on it. You know tool bars where you want them, grid turned off or on, units chosen etc. Save that file. Close Rhino, then open that file. Do not just open “Rhino”, rather open that saved file. Does it open with everything as you saved it? or are the toolbars moved? Just noodling to see if something clicks.


Hello - another thing to try is to run the installer again from the Windows control panel and choose ‘repair’. The Run as admin trick has worked in the past though - although I can’t swear I am not mixing up V5 and V6 behavior.


In case this comes up again, running repair still doesn’t fix it. I am getting really quick at rearranging my toolbars though.

Hi Pascal, will these Rhino V5 clean uninstall instructions work with V6 also?